summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-08 18:58:16 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-08 18:58:16 +0000
commit7122fa5fc275d50d647ba5b5fb572f90f19b137f (patch)
treeac300221dcd14d79bd4dcc6ff29dda4d9c8a5b0e /x11-wm/afterstep
parentx86 stable wrt bug #331623 (diff)
downloadgentoo-2-7122fa5fc275d50d647ba5b5fb572f90f19b137f.tar.gz
gentoo-2-7122fa5fc275d50d647ba5b5fb572f90f19b137f.tar.bz2
gentoo-2-7122fa5fc275d50d647ba5b5fb572f90f19b137f.zip
Respect LDFLAGS wrt bug 325309
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/ChangeLog6
-rw-r--r--x11-wm/afterstep/afterstep-2.2.9.ebuild5
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch37
3 files changed, 45 insertions, 3 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index 76e09825af56..744c51ab562f 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/afterstep
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.95 2010/07/04 09:14:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.96 2010/08/08 18:58:15 xarthisius Exp $
+
+ 08 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ afterstep-2.2.9.ebuild, +files/afterstep-2.2.9-ldflags.patch:
+ Respect LDFLAGS wrt bug 325309
04 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
afterstep-2.2.9.ebuild:
diff --git a/x11-wm/afterstep/afterstep-2.2.9.ebuild b/x11-wm/afterstep/afterstep-2.2.9.ebuild
index 5afeee8ec86d..19db9554e220 100644
--- a/x11-wm/afterstep/afterstep-2.2.9.ebuild
+++ b/x11-wm/afterstep/afterstep-2.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.14 2010/07/04 09:14:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.9.ebuild,v 1.15 2010/08/08 18:58:15 xarthisius Exp $
EAPI=2
inherit autotools flag-o-matic eutils
@@ -45,7 +45,8 @@ S=${WORKDIR}/AfterStep-${PV}
src_prepare() {
epatch "${FILESDIR}"/no-alternatives-${PV}.patch \
"${FILESDIR}"/${P}-make_session_data_file.patch \
- "${FILESDIR}"/${P}-alpha.patch
+ "${FILESDIR}"/${P}-alpha.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e '/CFLAGS="-O3"/d' \
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch b/x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch
new file mode 100644
index 000000000000..5d27d7d8293f
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch
@@ -0,0 +1,37 @@
+Respect LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=325309
+
+--- autoconf/Makefile.common.lib.in
++++ autoconf/Makefile.common.lib.in
+@@ -245,7 +245,7 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS)
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+ $(LIB_OBJS)
+
+ install: install.lib install.bin
+--- libAfterImage/Makefile.in
++++ libAfterImage/Makefile.in
+@@ -395,7 +395,7 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS) config.h
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+ $(LIB_OBJS)
+
+ install.man:
+--- libAfterBase/Makefile.in
++++ libAfterBase/Makefile.in
+@@ -325,7 +325,7 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS)
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+ $(USER_LD_FLAGS) $(LIBS_X) $(LIB_OBJS)
+
+ install: install.lib