summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-09-11 21:41:23 +0000
committerMichael Weber <xmw@gentoo.org>2011-09-11 21:41:23 +0000
commitaa8182dba7f79968c7d1a7861a10b8069946ae76 (patch)
treebb9780e15cb873020aba1180b46e09844a217efb /x11-wm/cwm
parent[app-emulation/xen-tools] Fix build (diff)
downloadgentoo-2-aa8182dba7f79968c7d1a7861a10b8069946ae76.tar.gz
gentoo-2-aa8182dba7f79968c7d1a7861a10b8069946ae76.tar.bz2
gentoo-2-aa8182dba7f79968c7d1a7861a10b8069946ae76.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/cwm')
-rw-r--r--x11-wm/cwm/ChangeLog7
-rw-r--r--x11-wm/cwm/cwm-20110908.ebuild34
-rw-r--r--x11-wm/cwm/cwm-99999999.ebuild4
3 files changed, 42 insertions, 3 deletions
diff --git a/x11-wm/cwm/ChangeLog b/x11-wm/cwm/ChangeLog
index 630e3c2a20ac..85b7d931557d 100644
--- a/x11-wm/cwm/ChangeLog
+++ b/x11-wm/cwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/cwm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.21 2011/09/11 21:21:49 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/ChangeLog,v 1.22 2011/09/11 21:41:23 xmw Exp $
+
+*cwm-20110908 (11 Sep 2011)
+
+ 11 Sep 2011; Michael Weber <xmw@gentoo.org> +cwm-20110908.ebuild:
+ Version bump to new tarball
11 Sep 2011; Michael Weber <xmw@gentoo.org> -cwm-20110213.ebuild,
cwm-20110515.ebuild:
diff --git a/x11-wm/cwm/cwm-20110908.ebuild b/x11-wm/cwm/cwm-20110908.ebuild
new file mode 100644
index 000000000000..eb7203f8e6d0
--- /dev/null
+++ b/x11-wm/cwm/cwm-20110908.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-20110908.ebuild,v 1.1 2011/09/11 21:41:23 xmw Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ http://github.com/chneukirchen/cwm"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20110726-Makefile.patch
+ export LDADD="${LDFLAGS}"
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/x11-wm/cwm/cwm-99999999.ebuild b/x11-wm/cwm/cwm-99999999.ebuild
index 74cde09ff61d..d0b70070af8f 100644
--- a/x11-wm/cwm/cwm-99999999.ebuild
+++ b/x11-wm/cwm/cwm-99999999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-99999999.ebuild,v 1.2 2011/08/04 22:27:34 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/cwm/cwm-99999999.ebuild,v 1.3 2011/09/11 21:41:23 xmw Exp $
EAPI=2
EGIT_REPO_URI=https://github.com/chneukirchen/cwm.git
EGIT_BRANCH=linux
-inherit eutils toolchain-funcs git
+inherit eutils toolchain-funcs git-2
DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/