summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-10-19 14:46:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-10-19 14:46:13 +0000
commit2fb23116999ab2b8462069dc0da366d88f439abe (patch)
tree72778b857a375a39fc59f30687ecf17c992be749 /x11-wm/icewm
parentVersion bump, bug 484084 (diff)
downloadgentoo-2-2fb23116999ab2b8462069dc0da366d88f439abe.tar.gz
gentoo-2-2fb23116999ab2b8462069dc0da366d88f439abe.tar.bz2
gentoo-2-2fb23116999ab2b8462069dc0da366d88f439abe.zip
Fix bug #486710
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog8
-rw-r--r--x11-wm/icewm/files/icewm-1.3.7-uclibc.patch64
-rw-r--r--x11-wm/icewm/icewm-1.3.7-r1.ebuild10
3 files changed, 75 insertions, 7 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index b88a442bac1b..27f15816b474 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/icewm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.156 2013/09/25 17:19:55 ago Exp $
+# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.157 2013/10/19 14:46:13 blueness Exp $
+
+ ; Anthony G. Basile <blueness@gentoo.org> +files/icewm-1.3.7-uclibc.patch,
+ icewm-1.3.7-r1.ebuild:
+ Fix bug #486710
25 Sep 2013; Agostino Sarubbo <ago@gentoo.org> icewm-1.3.7-r1.ebuild:
Stable for ppc, wrt bug #472086
diff --git a/x11-wm/icewm/files/icewm-1.3.7-uclibc.patch b/x11-wm/icewm/files/icewm-1.3.7-uclibc.patch
new file mode 100644
index 000000000000..e790842faed8
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.7-uclibc.patch
@@ -0,0 +1,64 @@
+diff -Naur icewm-1.3.7.orig/configure.in icewm-1.3.7/configure.in
+--- icewm-1.3.7.orig/configure.in 2010-10-31 10:09:37.000000000 -0400
++++ icewm-1.3.7/configure.in 2013-10-19 06:20:22.947520430 -0400
+@@ -113,6 +113,7 @@
+ AC_CHECK_HEADERS(libgen.h) dnl -- basename() for FreeBSD
+ AC_CHECK_HEADERS(machine/apmvar.h)
+ AC_CHECK_HEADERS(machine/apm_bios.h)
++AC_CHECK_HEADERS(execinfo.h)
+
+ AC_CHECK_HEADERS(kstat.h,
+ [ CORE_LIBS="${CORE_LIBS} -lkstat"
+diff -Naur icewm-1.3.7.orig/src/acpustatus.cc icewm-1.3.7/src/acpustatus.cc
+--- icewm-1.3.7.orig/src/acpustatus.cc 2010-10-31 10:09:36.000000000 -0400
++++ icewm-1.3.7/src/acpustatus.cc 2013-10-19 06:20:18.355519888 -0400
+@@ -25,17 +25,12 @@
+ #include "sysdep.h"
+ #include "default.h"
+
+-#if defined(linux)
+-//#include <linux/kernel.h>
+-#include <sys/sysinfo.h>
+-#endif
+ #if defined(sun) && defined(SVR4)
+ #include <sys/loadavg.h>
+ #endif
+ #ifdef HAVE_KSTAT_H
+ #include <sys/resource.h>
+ #include <kstat.h>
+-#include <sys/sysinfo.h>
+ #endif
+
+ #ifdef HAVE_SYS_PARAM_H
+@@ -56,6 +51,10 @@
+ #include <dirent.h>
+ #include "intl.h"
+
++#if defined(linux) || defined(HAVE_KSTAT_H)
++#include <sys/sysinfo.h>
++#endif
++
+ #if (defined(linux) || defined(HAVE_KSTAT_H)) || defined(HAVE_SYSCTL_CP_TIME)
+
+ extern ref<YPixmap> taskbackPixmap;
+diff -Naur icewm-1.3.7.orig/src/misc.cc icewm-1.3.7/src/misc.cc
+--- icewm-1.3.7.orig/src/misc.cc 2010-10-31 10:09:36.000000000 -0400
++++ icewm-1.3.7/src/misc.cc 2013-10-19 06:20:22.947520430 -0400
+@@ -15,7 +15,7 @@
+ #include <libgen.h>
+ #endif
+
+-#ifdef linux
++#if defined(linux) && defined(HAVE_EXECINFO_H)
+ #include <execinfo.h>
+ #endif
+
+@@ -503,7 +503,7 @@
+ }
+
+ void show_backtrace() {
+-#ifdef linux
++#if defined(linux) && defined(HAVE_EXECINFO_H)
+ const char head[] = "\nbacktrace:\n";
+ const char tail[] = "end\n";
+ void *array[20];
diff --git a/x11-wm/icewm/icewm-1.3.7-r1.ebuild b/x11-wm/icewm/icewm-1.3.7-r1.ebuild
index aa302a8f38aa..136cf3602a54 100644
--- a/x11-wm/icewm/icewm-1.3.7-r1.ebuild
+++ b/x11-wm/icewm/icewm-1.3.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999- Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.3.7-r1.ebuild,v 1.6 2013/09/25 17:19:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.3.7-r1.ebuild,v 1.7 2013/10/19 14:46:13 blueness Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -81,10 +81,10 @@ src_prepare() {
# Debian patch fixing multiple build issues, like bug #470148
epatch "${FILESDIR}"/${PN}-1.3.7-build-fixes.patch
- cd "${S}/src"
- use uclibc && epatch "${FILESDIR}/${PN}-uclibc.patch"
+ # Fix bug #486710
+ use uclibc && epatch "${FILESDIR}/${P}-uclibc.patch"
- cd "${S}"/ && eautoreconf
+ eautoreconf
}
src_configure() {