summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:00:52 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:00:52 +0000
commitf5f286ac820c13c41a9687f313ff3e4debfbbb5a (patch)
tree465265fbb7891e4b734a8739740ef7c7025216bb /x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
parentMerge pam-login back into shadow, as 4.x version was already being used; this... (diff)
downloadgentoo-2-f5f286ac820c13c41a9687f313ff3e4debfbbb5a.tar.gz
gentoo-2-f5f286ac820c13c41a9687f313ff3e4debfbbb5a.tar.bz2
gentoo-2-f5f286ac820c13c41a9687f313ff3e4debfbbb5a.zip
- Initial import. Original ebuild by Priit Laes, modifications by Björn Ruberg and Yuri Vasilevski.
(Portage version: 2.1_pre6)
Diffstat (limited to 'x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild')
-rw-r--r--x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
new file mode 100644
index 000000000000..056ee20021de
--- /dev/null
+++ b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild,v 1.1 2006/03/13 00:00:52 yvasilev Exp $
+
+inherit versionator
+
+DESCRIPTION="The Matchbox Desktop"
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="debug dnotify startup-notification"
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ startup-notification? ( x11-libs/startup-notification )"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-common"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable startup-notification) \
+ $(use_enable dnotify) \
+ || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}