summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-07-12 04:53:26 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-07-12 04:53:26 +0000
commit997a637e80d06d294708b9c6d0912bff94fcc366 (patch)
treebd92f045b079b27dd5ae40d3cf86c6c9fbf65a2f /x11-wm/metisse/metisse-0.3.5.ebuild
parentstable on mips (diff)
downloadgentoo-2-997a637e80d06d294708b9c6d0912bff94fcc366.tar.gz
gentoo-2-997a637e80d06d294708b9c6d0912bff94fcc366.tar.bz2
gentoo-2-997a637e80d06d294708b9c6d0912bff94fcc366.zip
Added wormo's fix from bug #91469.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-wm/metisse/metisse-0.3.5.ebuild')
-rw-r--r--x11-wm/metisse/metisse-0.3.5.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/x11-wm/metisse/metisse-0.3.5.ebuild b/x11-wm/metisse/metisse-0.3.5.ebuild
index 5cdf23da6597..79b705a025ac 100644
--- a/x11-wm/metisse/metisse-0.3.5.ebuild
+++ b/x11-wm/metisse/metisse-0.3.5.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metisse/metisse-0.3.5.ebuild,v 1.4 2005/04/23 00:36:46 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metisse/metisse-0.3.5.ebuild,v 1.5 2005/07/12 04:53:26 josejx Exp $
+
+inherit eutils
# fc is broken
-IUSE="truetype xv opengl"
+IUSE="truetype xv opengl mmx"
DESCRIPTION="Experimental X desktop with some OpenGL capacity."
SRC_URI="http://insitu.lri.fr/~chapuis/software/metisse/${P}.tar.bz2"
@@ -19,6 +21,13 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc -amd64"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/metisse-0.3.5-mmx-config.patch
+ libtoolize --copy --force
+}
+
src_compile() {
local myconf
if use opengl && use x86 ; then
@@ -29,6 +38,10 @@ src_compile() {
myconf="${myconf} --disable-glx --disable-glx-x86"
fi
+ if use mmx ; then
+ myconf="${myconf} --enable-mmx"
+ fi
+
econf \
$(use_enable xv) \
$(use_enable truetype freetype) \