summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Hale <tseng@gentoo.org>2004-05-06 16:20:41 +0000
committerBrandon Hale <tseng@gentoo.org>2004-05-06 16:20:41 +0000
commitb1550cfbf777686d9db389ef08e7a6763c5e9d97 (patch)
tree58afef22b2863a00e2dddf9c00d39fbab6656423 /x11-wm/openbox
parentStable on x86. (Manifest recommit) (diff)
downloadgentoo-2-b1550cfbf777686d9db389ef08e7a6763c5e9d97.tar.gz
gentoo-2-b1550cfbf777686d9db389ef08e7a6763c5e9d97.tar.bz2
gentoo-2-b1550cfbf777686d9db389ef08e7a6763c5e9d97.zip
Apply Makefile fix from bug #50190.
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog8
-rw-r--r--x11-wm/openbox/files/digest-openbox-3.2-r12
-rw-r--r--x11-wm/openbox/files/openbox-3.2-makefile.patch14
-rw-r--r--x11-wm/openbox/openbox-3.2-r1.ebuild59
4 files changed, 82 insertions, 1 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 1e84d6416f56..4a729a4f0c41 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.79 2004/04/27 17:59:52 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.80 2004/05/06 16:20:41 tseng Exp $
+
+*openbox-3.2-r1 (06 May 2004)
+
+ 06 May 2004; Brandon Hale <tseng@gentoo.org>
+ +files/openbox-3.2-makefile.patch, +openbox-3.2-r1.ebuild:
+ Apply Makefile fix from bug #50190.
27 Apr 2004; Gustavo Zacarias <gustavoz@gentoo.org> openbox-3.2.ebuild:
Keyworded sparc
diff --git a/x11-wm/openbox/files/digest-openbox-3.2-r1 b/x11-wm/openbox/files/digest-openbox-3.2-r1
new file mode 100644
index 000000000000..40daee057d5f
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-3.2-r1
@@ -0,0 +1,2 @@
+MD5 96b6393839883c4b260388879154d294 openbox-3.2.tar.gz 561115
+MD5 3d69bb394dae0994461172fccedc602a ob-themes-usability.tar.bz2 19204
diff --git a/x11-wm/openbox/files/openbox-3.2-makefile.patch b/x11-wm/openbox/files/openbox-3.2-makefile.patch
new file mode 100644
index 000000000000..f50fa086f15a
--- /dev/null
+++ b/x11-wm/openbox/files/openbox-3.2-makefile.patch
@@ -0,0 +1,14 @@
+--- Makefile.am.orig 2004-05-06 01:59:08.943196669 -0700
++++ Makefile.am 2004-05-06 02:02:30.184343747 -0700
+@@ -55,6 +55,11 @@
+ -DDEFAULT_THEME=\"$(theme)\"
+ render_libobrender_la_LDFLAGS = \
+ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
++render_libobrender_la_LIBADD = \
++ $(X_LIBS) \
++ $(XFT_LIBS) \
++ $(GLIB_LIBS) \
++ $(XML_LIBS)
+ render_libobrender_la_SOURCES = \
+ gettext.h \
+ render/color.h \
diff --git a/x11-wm/openbox/openbox-3.2-r1.ebuild b/x11-wm/openbox/openbox-3.2-r1.ebuild
new file mode 100644
index 000000000000..8ba99271d1d6
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.2-r1.ebuild,v 1.1 2004/05/06 16:20:41 tseng Exp $
+
+S=${WORKDIR}/${P/_/-}
+DESCRIPTION="Openbox is a standards compliant, fast, light-weight, extensible window manager."
+
+SRC_URI="http://icculus.org/openbox/releases/${P/_/-}.tar.gz
+ mirror://gentoo/ob-themes-usability.tar.bz2"
+
+HOMEPAGE="http://icculus.org/openbox/"
+IUSE="nls"
+SLOT="3"
+
+RDEPEND="virtual/xft
+ virtual/x11
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2
+ >=dev-libs/libxml2-2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.patch
+}
+
+src_compile() {
+
+ econf \
+ `use_enable nls` || die
+ emake || die
+}
+
+src_install () {
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ fperms a+x /etc/X11/Sessions/openbox
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/${PN}.desktop
+
+ make DESTDIR=${D} install || die
+ dodoc README AUTHORS ChangeLog TODO
+
+ # Extra styles from http://home.clara.co.uk/dpb/openbox.htm
+ # These are included due to the poor usability of the default themes
+ # for users with limited vision. These are based on Jimmac's
+ # Gorilla and Industrial themes for Metacity.
+
+ dodir /usr/share/themes
+ cp -a ${WORKDIR}/ob-themes-usability/* ${D}/usr/share/themes
+}