summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-04-15 21:45:13 +0000
committerPeter Gavin <pete@gentoo.org>2001-04-15 21:45:13 +0000
commit307c31ab4728ff8fd3be0a6ef761b0fc8d4a562d (patch)
tree0df505d8c4e7a71394e306c3ca152835d64d4417 /x11-wm/sawfish
parentmore gnome updates (diff)
downloadgentoo-2-307c31ab4728ff8fd3be0a6ef761b0fc8d4a562d.tar.gz
gentoo-2-307c31ab4728ff8fd3be0a6ef761b0fc8d4a562d.tar.bz2
gentoo-2-307c31ab4728ff8fd3be0a6ef761b0fc8d4a562d.zip
even more gnome updates (yay!)
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-0.381
-rw-r--r--x11-wm/sawfish/sawfish-0.38.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-wm/sawfish/files/digest-sawfish-0.38 b/x11-wm/sawfish/files/digest-sawfish-0.38
new file mode 100644
index 000000000000..2c1e40a9024f
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-0.38
@@ -0,0 +1 @@
+MD5 f9da1e553d427f61c36e850aa7cf1b7b sawfish-0.38.tar.gz
diff --git a/x11-wm/sawfish/sawfish-0.38.ebuild b/x11-wm/sawfish/sawfish-0.38.ebuild
new file mode 100644
index 000000000000..fc4c223e5d26
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-0.38.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-0.38.ebuild,v 1.1 2001/04/15 21:45:13 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://sawmill.sourceforge.net/pub/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+DEPEND=">=dev-libs/rep-gtk-0.15-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )
+ >=media-libs/audiofile-0.2.1
+ >=media-libs/imlib-1.9.9
+ gnome? ( >=gnome-base/gnome-core-1.4.0
+ >=gnome-base/libglade-0.16-r1 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use esd`" ]
+ then
+ myconf="--with-esd"
+ else
+ myconf="--without-esd"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="${myconf} --with-gnome-prefix=/opt/gnome --enable-gnome-widgets --enable-capplet"
+ else
+ myconf="${myconf} --disable-gnome-widgets --disable-capplet"
+ fi
+ if [ "`use readline`" ]
+ then
+ myconf="${myconf} --with-readline"
+ else
+ myconf="${myconf} --without-readline"
+ fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-linguas"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --infodir=/usr/X11R6/share/info --libexecdir=/usr/X11R6/lib --with-audiofile ${myconf}
+
+ #pmake doesn't work, stick with make
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+}
+
+
+