summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 06:05:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 06:05:34 +0000
commit345a8b7931e78718557d6fb6959e8b9faf35845b (patch)
treed59e66683ee16a8727fd7427d36872ac504f137a /x11-wm/sawfish
parent*** empty log message *** (diff)
downloadgentoo-2-345a8b7931e78718557d6fb6959e8b9faf35845b.tar.gz
gentoo-2-345a8b7931e78718557d6fb6959e8b9faf35845b.tar.bz2
gentoo-2-345a8b7931e78718557d6fb6959e8b9faf35845b.zip
Updates
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/sawfish-0.37.3-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-wm/sawfish/sawfish-0.37.3-r1.ebuild b/x11-wm/sawfish/sawfish-0.37.3-r1.ebuild
new file mode 100644
index 000000000000..81c4bdbce26a
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-0.37.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-0.37.3-r1.ebuild,v 1.1 2001/03/06 06:05:34 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://sawmill.sourceforge.net/pub/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+DEPEND=">=dev-libs/rep-gtk-0.15-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )
+ >=media-libs/audiofile-0.2.1
+ >=media-libs/imlib-1.9.9
+ gnome? ( >=gnome-base/gnome-core-1.3.1
+ >=gnome-base/libglade-0.15-r1 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use esd`" ]
+ then
+ myconf="--with-esd"
+ else
+ myconf="--without-esd"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="${myconf} --with-gnome-prefix=/opt/gnome --enable-gnome-widgets --enable-capplet"
+ else
+ myconf="${myconf} --disable-gnome-widgets --disable-capplet"
+ fi
+ if [ "`use readline`" ]
+ then
+ myconf="${myconf} --with-readline"
+ else
+ myconf="${myconf} --without-readline"
+ fi
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-linguas"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr/X11R6 --infodir=/usr/X11R6/share/info --libexecdir=/usr/X11R6/lib --with-audiofile ${myconf}
+
+ #pmake doesn't work, stick with make
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+}
+
+
+