summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2009-11-25 20:58:35 +0000
committerHarald van Dijk <truedfx@gentoo.org>2009-11-25 20:58:35 +0000
commitb4cdc33ce5e1f13955ab30065a39168998ddcd28 (patch)
treea73e87147a560fb384c0a3a6d1d312073f8c7530 /x11-wm/sawfish
parentMoving www-plugins/mozilla-weave to www-plugins/weave. (diff)
downloadgentoo-2-b4cdc33ce5e1f13955ab30065a39168998ddcd28.tar.gz
gentoo-2-b4cdc33ce5e1f13955ab30065a39168998ddcd28.tar.bz2
gentoo-2-b4cdc33ce5e1f13955ab30065a39168998ddcd28.zip
Version bumps
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog9
-rw-r--r--x11-wm/sawfish/sawfish-1.5.3.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index c7757a137464..2ead91996711 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.90 2009/03/08 20:06:33 truedfx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.91 2009/11/25 20:58:35 truedfx Exp $
+
+*sawfish-1.5.3 (25 Nov 2009)
+
+ 25 Nov 2009; Harald van Dijk <truedfx@gentoo.org> +sawfish-1.5.3.ebuild:
+ Version bump
*sawfish-1.3.5.2 (08 Mar 2009)
diff --git a/x11-wm/sawfish/sawfish-1.5.3.ebuild b/x11-wm/sawfish/sawfish-1.5.3.ebuild
new file mode 100644
index 000000000000..2dc0bf566339
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.5.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.5.3.ebuild,v 1.1 2009/11/25 20:58:35 truedfx Exp $
+
+# detect cvs snapshots; fex. 1.3_p20040120
+[[ $PV == *_p[0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9] ]]
+(( snapshot = !$? ))
+
+if (( snapshot )); then
+ inherit eutils autotools
+else
+ inherit eutils
+fi
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+if (( snapshot )); then
+ SRC_URI="mirror://gentoo/${P/_p/.}.tar.bz2"
+else
+ SRC_URI="mirror://sourceforge/sawmill/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="audiofile esd nls"
+
+RDEPEND=">=dev-libs/librep-0.90.0
+ >=x11-libs/rep-gtk-0.90.0
+ >=x11-libs/pango-1.8.0
+ >=x11-libs/gtk+-2.6.0
+ audiofile? ( >=media-libs/audiofile-0.2.3 )
+ esd? ( >=media-sound/esound-0.2.23 )
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+if (( snapshot )); then
+ S="${WORKDIR}/${PN}"
+fi
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if (( snapshot )); then
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ set -- \
+ --with-gdk-pixbuf \
+ $(use_with audiofile) \
+ $(use_with esd)
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@" || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+}