summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-11-17 11:50:53 +0000
committerTilman Klar <phoenix@gentoo.org>2002-11-17 11:50:53 +0000
commitd254226ef0929f62cfade3192c00cf40d1587fe8 (patch)
tree6470bbce9630acb73f242b02701a487db818c946 /x11-wm/sawfish
parentVersion bump. Needed for sawfish-1.2. (diff)
downloadgentoo-2-d254226ef0929f62cfade3192c00cf40d1587fe8.tar.gz
gentoo-2-d254226ef0929f62cfade3192c00cf40d1587fe8.tar.bz2
gentoo-2-d254226ef0929f62cfade3192c00cf40d1587fe8.zip
Version bump.
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/ChangeLog9
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.21
-rw-r--r--x11-wm/sawfish/sawfish-1.2.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 14792a10c77c..37078111617d 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.14 2002/10/19 23:19:19 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.15 2002/11/17 11:50:53 phoenix Exp $
+
+*sawfish-1.2 (17 Nov 2002)
+
+ 17 Nov 2002; phoen][x <phoenix@gentoo.org> sawfish-1.2.ebuild,
+ files/digest-sawfish-1.2.ebuild :
+ Version bump. Forcing the ebuild to use the gtk2 version of sawfish-1.2.
+ Maybe i'll add some optional USEflag SRC_URI later.
*sawfish-1.0.1-r6 (15 Oct 2002)
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.2 b/x11-wm/sawfish/files/digest-sawfish-1.2
new file mode 100644
index 000000000000..0941e220244d
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.2
@@ -0,0 +1 @@
+MD5 bab6b11a6e7af758606d53cb44b003ab sawfish-1.2-gtk2.tar.gz 1574246
diff --git a/x11-wm/sawfish/sawfish-1.2.ebuild b/x11-wm/sawfish/sawfish-1.2.ebuild
new file mode 100644
index 000000000000..fae6dd7af5aa
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.2.ebuild,v 1.1 2002/11/17 11:50:53 phoenix Exp $
+
+IUSE="readline esd nls"
+
+MY_P="${P}-gtk2"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="mirror://sourceforge/sawmill/${MY_P}.tar.gz"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-0.17
+ ( >=dev-libs/librep-0.16
+ <dev-libs/librep-20020000 )
+ >=media-libs/imlib-1.9.10-r1
+ media-libs/audiofile
+ >=x11-libs/gtk+-2.1.2
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+
+ local myconf=""
+ use esd && myconf="${myconf} --with-esd"
+ use esd || myconf="${myconf} --without-esd"
+
+ use readline && myconf="${myconf} --with-readline"
+ use readline || myconf="${myconf} --without-readline"
+
+ use nls || myconf="${myconf} --disable-linguas"
+
+ # The themer is currently broken (must have rep-gtk-0.15
+ # installed to get it compiled) - Azarah, 24 Jun 2002
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-gnome-prefix=/usr \
+ --enable-gnome-widgets \
+ --enable-capplet \
+ --disable-themer \
+ --with-gdk-pixbuf \
+ --with-audiofile \
+ ${myconf} || die
+
+ # DO NOT USE "emake" !!! - Azarah, 24 Jun 2002
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+}
+
+
+