summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-03 09:53:35 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-03 09:53:35 +0000
commit925be9905e5a5c81f66f08ebec8b37ab5651bc40 (patch)
tree4be5f3f7888062bd08de102925b6ec46ae13d58c /x11-wm/waimea/waimea-0.5.0_pre040506.ebuild
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-925be9905e5a5c81f66f08ebec8b37ab5651bc40.tar.gz
gentoo-2-925be9905e5a5c81f66f08ebec8b37ab5651bc40.tar.bz2
gentoo-2-925be9905e5a5c81f66f08ebec8b37ab5651bc40.zip
Version bump
Diffstat (limited to 'x11-wm/waimea/waimea-0.5.0_pre040506.ebuild')
-rw-r--r--x11-wm/waimea/waimea-0.5.0_pre040506.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild b/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild
new file mode 100644
index 000000000000..ea1c6bc73a76
--- /dev/null
+++ b/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/waimea/waimea-0.5.0_pre040506.ebuild,v 1.1 2004/06/03 09:53:35 dholm Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${PN}-0.5.0"
+DESCRIPTION="Window manager based on BlackBox"
+# Temporary URL until SF's CVS is back online
+SRC_URI="http://www.cs.umu.se/~c99drn/waimea/waimea-0.5.0-040506.tar.gz"
+HOMEPAGE="http://www.waimea.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="truetype xinerama"
+
+DEPEND="virtual/x11
+ x11-libs/cairo
+ x11-libs/libsvg-cairo"
+
+PROVIDE="virtual/blackbox"
+
+src_compile() {
+ econf \
+ `use_enable xinerama` \
+ `use_enable truetype xft` \
+ --enable-svg \
+ --enable-shape \
+ --enable-render \
+ --enable-randr \
+ --enable-pixmap \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall sysconfdir=${D}/etc/X11/waimea || die
+
+ dodoc ChangeLog AUTHORS COPYING INSTALL README TODO NEWS
+
+ exeinto /etc/X11/Sessions
+ echo "/usr/bin/waimea" > waimea
+ doexe waimea
+}
+
+pkg_postinst() {
+ einfo "Please read the README in /usr/share/doc/${PF}"
+ einfo "for info on setting up and configuring waimea"
+}