summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-02-22 14:10:46 +0000
committerAlex Alexander <wired@gentoo.org>2011-02-22 14:10:46 +0000
commit0e90ee129f5fafdcb79fd828066ac40f5089ccb9 (patch)
tree292574abc507dd4732697e7d9f8b204a5bc98b48 /x11-wm
parentVersion bump (diff)
downloadgentoo-2-0e90ee129f5fafdcb79fd828066ac40f5089ccb9.tar.gz
gentoo-2-0e90ee129f5fafdcb79fd828066ac40f5089ccb9.tar.bz2
gentoo-2-0e90ee129f5fafdcb79fd828066ac40f5089ccb9.zip
fixed compilation with cmake-2.8.4, bug #356009
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/awesome/ChangeLog7
-rw-r--r--x11-wm/awesome/awesome-3.4.4.ebuild5
-rw-r--r--x11-wm/awesome/awesome-3.4.8.ebuild3
-rw-r--r--x11-wm/awesome/awesome-3.4.9.ebuild3
-rw-r--r--x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch40
-rw-r--r--x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch23
6 files changed, 76 insertions, 5 deletions
diff --git a/x11-wm/awesome/ChangeLog b/x11-wm/awesome/ChangeLog
index b86622002487..343223fbe50d 100644
--- a/x11-wm/awesome/ChangeLog
+++ b/x11-wm/awesome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/awesome
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/ChangeLog,v 1.116 2011/01/23 13:54:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/ChangeLog,v 1.117 2011/02/22 14:10:46 wired Exp $
+
+ 22 Feb 2011; Alex Alexander <wired@gentoo.org> awesome-3.4.4.ebuild,
+ +files/awesome-3.4.4-cmake-2.8.4.patch, awesome-3.4.8.ebuild,
+ +files/awesome-3.4.8-cmake-2.8.4.patch, awesome-3.4.9.ebuild:
+ fixed compilation with cmake-2.8.4, bug #356009
23 Jan 2011; Markos Chandras <hwoarang@gentoo.org> awesome-3.4.8.ebuild:
Stable on amd64 wrt bug #352249
diff --git a/x11-wm/awesome/awesome-3.4.4.ebuild b/x11-wm/awesome/awesome-3.4.4.ebuild
index 6dc124758ac2..793ad46c9bad 100644
--- a/x11-wm/awesome/awesome-3.4.4.ebuild
+++ b/x11-wm/awesome/awesome-3.4.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.4.4.ebuild,v 1.8 2010/11/05 23:42:06 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.4.4.ebuild,v 1.9 2011/02/22 14:10:46 wired Exp $
EAPI="2"
inherit cmake-utils eutils
@@ -60,6 +60,7 @@ mycmakeargs="-DPREFIX=/usr
src_prepare() {
epatch "${FILESDIR}/${PN}-3.4.2-backtrace.patch"
+ epatch "${FILESDIR}/${PN}-3.4.4-cmake-2.8.4.patch"
}
src_compile() {
diff --git a/x11-wm/awesome/awesome-3.4.8.ebuild b/x11-wm/awesome/awesome-3.4.8.ebuild
index 89d974be2846..7d65c8d84960 100644
--- a/x11-wm/awesome/awesome-3.4.8.ebuild
+++ b/x11-wm/awesome/awesome-3.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.4.8.ebuild,v 1.9 2011/01/23 13:54:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.4.8.ebuild,v 1.10 2011/02/22 14:10:46 wired Exp $
EAPI="3"
inherit cmake-utils eutils
@@ -73,6 +73,7 @@ DOCS="AUTHORS BUGS PATCHES README STYLE"
src_prepare() {
epatch "${FILESDIR}/${PN}-3.4.2-backtrace.patch"
+ epatch "${FILESDIR}/${PN}-3.4.8-cmake-2.8.4.patch"
}
src_configure() {
diff --git a/x11-wm/awesome/awesome-3.4.9.ebuild b/x11-wm/awesome/awesome-3.4.9.ebuild
index a937fbd05c23..01032b981314 100644
--- a/x11-wm/awesome/awesome-3.4.9.ebuild
+++ b/x11-wm/awesome/awesome-3.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.4.9.ebuild,v 1.3 2011/01/22 03:49:15 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-3.4.9.ebuild,v 1.4 2011/02/22 14:10:46 wired Exp $
EAPI="3"
CMAKE_MIN_VERSION="2.8"
@@ -72,6 +72,7 @@ DOCS="AUTHORS BUGS PATCHES README STYLE"
src_prepare() {
epatch "${FILESDIR}/${PN}-3.4.2-backtrace.patch"
+ epatch "${FILESDIR}/${PN}-3.4.8-cmake-2.8.4.patch"
}
src_configure() {
diff --git a/x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch b/x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch
new file mode 100644
index 000000000000..5f2a7f949427
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch
@@ -0,0 +1,40 @@
+fix compilation with cmake 2.8.4 by backporting some changes from 3.8.9 and applying
+ https://awesome.naquadah.org/bugs/index.php?do=details&task_id=869
+
+https://bugs.gentoo.org/show_bug.cgi?id=356009
+--- awesome-3.4.4-orig/CMakeLists.txt 2011-02-22 15:26:17.380000002 +0200
++++ CMakeLists.txt 2011-02-22 16:03:40.219000002 +0200
+@@ -249,22 +249,24 @@
+ # }}}
+
+ # {{{ Theme icons
+-file(GLOB icon_sources ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
++file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
++
++foreach(icon ${icon_sources})
++ # Copy all icons to the build dir to simplify the following code.
++ # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
++ # relative to ${BUILD_DIR}.
++ get_filename_component(icon_path ${icon} PATH)
++ get_filename_component(icon_name ${icon} NAME)
++ file(COPY ${icon} DESTINATION ${icon_path})
++ set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
++endforeach()
+
+ macro(a_icon_convert match replacement input)
+ string(REPLACE ${match} ${replacement} output ${input})
+
+ if(NOT ${input} STREQUAL ${output})
+- if(NOT ${output} MATCHES ${BUILD_DIR})
+- string(REPLACE ${SOURCE_DIR} ${BUILD_DIR} output ${output})
+- endif()
+-
+ set(ALL_ICONS ${ALL_ICONS} ${output})
+
+- get_filename_component(output_path ${output} PATH)
+- file(MAKE_DIRECTORY ${output_path})
+-
+ add_custom_command(
+ COMMAND ${CONVERT_EXECUTABLE} ${input} ${ARGN} ${output}
+ OUTPUT ${output}
diff --git a/x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch b/x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch
new file mode 100644
index 000000000000..bfa7ab002c61
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch
@@ -0,0 +1,23 @@
+fix compilation with cmake 2.8.4
+
+https://awesome.naquadah.org/bugs/index.php?do=details&task_id=869
+https://bugs.gentoo.org/show_bug.cgi?id=356009
+--- awesome-3.4.9/CMakeLists.txt.orig
++++ awesome-3.4.9/CMakeLists.txt
+@@ -274,14 +274,15 @@ endif()
+
+ # {{{ Theme icons
+ file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
+
+ foreach(icon ${icon_sources})
+ # Copy all icons to the build dir to simplify the following code.
+ # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
+ # relative to ${BUILD_DIR}.
+ get_filename_component(icon_path ${icon} PATH)
++ get_filename_component(icon_name ${icon} NAME)
+ file(COPY ${icon} DESTINATION ${icon_path})
++ set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
+ endforeach()
+
+ macro(a_icon_convert match replacement input)