summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-04-26 19:44:58 +0000
committerJeroen Roovers <jer@gentoo.org>2014-04-26 19:44:58 +0000
commit228ce47cf75c2a8ce56b227e00a1d07c278007fb (patch)
tree52682f2d6d7fe0f9f3e93f8c8b64e8d19d619777 /x11-wm
parentdrop old (diff)
downloadgentoo-2-228ce47cf75c2a8ce56b227e00a1d07c278007fb.tar.gz
gentoo-2-228ce47cf75c2a8ce56b227e00a1d07c278007fb.tar.bz2
gentoo-2-228ce47cf75c2a8ce56b227e00a1d07c278007fb.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ratpoison/ChangeLog7
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.7.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 7769b2433bff..73b099af2255 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ratpoison
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.97 2014/03/08 20:26:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.98 2014/04/26 19:44:58 jer Exp $
+
+*ratpoison-1.4.7 (26 Apr 2014)
+
+ 26 Apr 2014; Jeroen Roovers <jer@gentoo.org> +ratpoison-1.4.7.ebuild:
+ Version bump.
08 Mar 2014; Jeroen Roovers <jer@gentoo.org> ratpoison-1.4.6-r1.ebuild:
Fix IUSE sort order.
diff --git a/x11-wm/ratpoison/ratpoison-1.4.7.ebuild b/x11-wm/ratpoison/ratpoison-1.4.7.ebuild
new file mode 100644
index 000000000000..f673b492d087
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.7.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.7.ebuild,v 1.1 2014/04/26 19:44:58 jer Exp $
+
+EAPI=5
+
+inherit elisp-common eutils toolchain-funcs
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug emacs +history sloppy +xft"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )
+ virtual/perl-PodParser
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+SITEFILE=50ratpoison-gentoo.el
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with xft) \
+ $(usex history '' --disable-history)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ fi
+
+ if use sloppy; then
+ pushd contrib
+ $(tc-getCC) \
+ ${CFLAGS} \
+ ${LDFLAGS} \
+ -o sloppy{,.c} \
+ $( $(tc-getPKG_CONFIG) --libs x11) \
+ || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/ratpoison.xsession ratpoison
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ use sloppy && dobin contrib/sloppy
+
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${ED}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}