summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-08-14 15:48:59 +0000
committerMichael Januszewski <spock@gentoo.org>2006-08-14 15:48:59 +0000
commit2361bc2211c8a58e77bc24d0459043a184d681cd (patch)
tree4132ce68a466be5535487bb908b95b1ea57ef5ff /x11-wm
parentnew release and fix download URI of 4.2 (diff)
downloadgentoo-2-2361bc2211c8a58e77bc24d0459043a184d681cd.tar.gz
gentoo-2-2361bc2211c8a58e77bc24d0459043a184d681cd.tar.bz2
gentoo-2-2361bc2211c8a58e77bc24d0459043a184d681cd.zip
Version bump on request of the upstream developer.
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog8
-rw-r--r--x11-wm/afterstep/afterstep-2.2.2.ebuild133
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.2.23
3 files changed, 143 insertions, 1 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index ab99ab7d1f70..ba817ac6b281 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/afterstep
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.56 2006/05/23 20:32:58 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.57 2006/08/14 15:48:59 spock Exp $
+
+*afterstep-2.2.2 (14 Aug 2006)
+
+ 14 Aug 2006; Michał Januszewski <spock@gentoo.org>
+ +afterstep-2.2.2.ebuild:
+ Version bump on request of the upstream developer.
23 May 2006; Markus Rothe <corsair@gentoo.org> afterstep-2.2.0.ebuild:
Stable on ppc64
diff --git a/x11-wm/afterstep/afterstep-2.2.2.ebuild b/x11-wm/afterstep/afterstep-2.2.2.ebuild
new file mode 100644
index 000000000000..26d289398e65
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.2.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.2.ebuild,v 1.1 2006/08/14 15:48:59 spock Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+
+LICENSE="AFTERSTEP"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gif jpeg mmx nls png tiff xinerama"
+
+RDEPEND="virtual/libc
+ media-libs/freetype
+ debug? ( !hppa? ( !ppc? ( dev-util/efence ) ) )
+ png? ( >=media-libs/libpng-1.2.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )"
+
+S="${WORKDIR}/AfterStep-${PV}"
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+ --enable-audit --enable-trace --enable-trace-x"
+
+ if ! use ppc && use debug ; then
+ myconf="${myconf} --with-libefence"
+ fi
+
+ #implied intent of debug means you need the frame pointers.
+ use debug && filter-flags -fomit-frame-pointer
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --with-ungif=no - Use giflib instead of libungif
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+
+ econf \
+ $(use_enable nls i18n) \
+ $(use_enable mmx mmx-optimization) \
+ $(use_enable xinerama) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with gif) \
+ $(use_with tiff) \
+ --with-helpcommand="xterm -e man" \
+ --with-ungif=no \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # see bug #31541
+ dodir /usr/share/gnome/wm-properties
+
+ # afterstep tries to detect the current resolution
+ # for documentation generation, causing access violations
+ # for the video device. bug #87356
+ unset DISPLAY
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ # This fixes a bug with shared libraries
+ rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
+ cp -pPR ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterConf/libAfterConf.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterStep/libAfterStep.so* ${D}/usr/lib
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm ${D}/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -pPR ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ newins ${S}/AfterStep.desktop.final AfterStep.desktop
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/afterstep
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use AfterStep issue the following commands:"
+ einfo "mv ~/.xinitrc ~/xinitrc.old"
+ einfo "echo afterstep > ~/.xinitrc"
+ echo
+ einfo "If you like AfterStep please vote for it at"
+ einfo "http://www.PLiG.org/xwinman/vote.html !"
+ echo
+}
+
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.2.2 b/x11-wm/afterstep/files/digest-afterstep-2.2.2
new file mode 100644
index 000000000000..24f0c968a1fa
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-2.2.2
@@ -0,0 +1,3 @@
+MD5 dbfe86bfe20c8c377985c7e68232b570 AfterStep-2.2.2.tar.bz2 5458624
+RMD160 0a314423218f138e6041bcae0cfa18b565231a61 AfterStep-2.2.2.tar.bz2 5458624
+SHA256 57657c8374c96aef8a9eeb0aa717aae3a38862bce9c9d389f69378bc8cc9fd65 AfterStep-2.2.2.tar.bz2 5458624