summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-08 21:31:51 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-08 21:31:51 +0000
commit2b94783e6d7f7aa2fc70755b0f1772d5db9f0612 (patch)
treead12692a9291a71aed69e4d063520515ac28351a /x11-wm
parentquote ${D} variable, bug #258163 (diff)
downloadgentoo-2-2b94783e6d7f7aa2fc70755b0f1772d5db9f0612.tar.gz
gentoo-2-2b94783e6d7f7aa2fc70755b0f1772d5db9f0612.tar.bz2
gentoo-2-2b94783e6d7f7aa2fc70755b0f1772d5db9f0612.zip
Add patch to fix crash on login.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/ChangeLog8
-rw-r--r--x11-wm/metacity/files/metacity-2.24.0-crash-login.patch52
-rw-r--r--x11-wm/metacity/metacity-2.24.0-r1.ebuild54
3 files changed, 113 insertions, 1 deletions
diff --git a/x11-wm/metacity/ChangeLog b/x11-wm/metacity/ChangeLog
index 1f4469cabcb1..b8eaf28bb2bc 100644
--- a/x11-wm/metacity/ChangeLog
+++ b/x11-wm/metacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/metacity
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.221 2009/01/31 11:46:54 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.222 2009/02/08 21:31:50 eva Exp $
+
+*metacity-2.24.0-r1 (08 Feb 2009)
+
+ 08 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/metacity-2.24.0-crash-login.patch, +metacity-2.24.0-r1.ebuild:
+ Add patch to fix crash on login.
31 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+files/metacity-2.24.0-fbsd.patch, metacity-2.20.1.ebuild,
diff --git a/x11-wm/metacity/files/metacity-2.24.0-crash-login.patch b/x11-wm/metacity/files/metacity-2.24.0-crash-login.patch
new file mode 100644
index 000000000000..f274f4cc05a2
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.24.0-crash-login.patch
@@ -0,0 +1,52 @@
+# https://bugzilla.gnome.org/show_bug.cgi?id=553980
+--- a/src/core/main.c 2008-10-08 00:10:39.000000000 -0400
++++ b/src/core/main.c 2008-10-08 00:18:44.000000000 -0400
+@@ -312,6 +312,23 @@ void meta_select_display (gchar *display
+ /* DO NOT FREE envVar, putenv() sucks */
+ putenv (envVar);
+ }
++
++static
++void meta_finalize (void)
++{
++ meta_display_close (meta_get_display (),
++ CurrentTime); /* I doubt correct timestamps matter here */
++
++ meta_session_shutdown ();
++}
++
++static
++void sigterm_handler (int signum)
++{
++ meta_finalize ();
++
++ exit (meta_exit_code);
++}
+
+ /**
+ * This is where the story begins. It parses commandline options and
+@@ -352,6 +369,11 @@ main (int argc, char **argv)
+ g_strerror (errno));
+ #endif
+
++ act.sa_handler = &sigterm_handler;
++ if (sigaction (SIGTERM, &act, NULL) < 0)
++ g_printerr ("Failed to register SIGTERM handler: %s\n",
++ g_strerror (errno));
++
+ if (g_getenv ("METACITY_VERBOSE"))
+ meta_set_verbose (TRUE);
+ if (g_getenv ("METACITY_DEBUG"))
+@@ -478,11 +500,8 @@ main (int argc, char **argv)
+
+ g_main_loop_run (meta_main_loop);
+
+- meta_display_close (meta_get_display (),
+- CurrentTime); /* I doubt correct timestamps matter here */
++ meta_finalize ();
+
+- meta_session_shutdown ();
+-
+ if (meta_restart_after_quit)
+ {
+ GError *err;
diff --git a/x11-wm/metacity/metacity-2.24.0-r1.ebuild b/x11-wm/metacity/metacity-2.24.0-r1.ebuild
new file mode 100644
index 000000000000..c120eecb1504
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.24.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.24.0-r1.ebuild,v 1.1 2009/02/08 21:31:50 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME default window manager"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=x11-libs/pango-1.2
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXcursor
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libSM
+ x11-libs/libICE
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable xinerama)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix compilation on *bsd, bug #256224
+ epatch "${FILESDIR}/${P}-fbsd.patch"
+
+ # Fix crash on login, upstream bug #553980
+ epatch "${FILESDIR}/${P}-crash-login.patch"
+}