summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-07-31 00:30:10 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-07-31 00:30:10 +0000
commit6a22cde2cb5be4ffbef1339aea1cadb9313998e9 (patch)
tree5cc0fe9bd573d55687a3ff68f18a2760bfae4912 /x11-wm
parentfvwm fixes (diff)
downloadgentoo-2-6a22cde2cb5be4ffbef1339aea1cadb9313998e9.tar.gz
gentoo-2-6a22cde2cb5be4ffbef1339aea1cadb9313998e9.tar.bz2
gentoo-2-6a22cde2cb5be4ffbef1339aea1cadb9313998e9.zip
warning about new USE flags
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/ChangeLog5
-rw-r--r--x11-wm/fvwm/Manifest4
-rw-r--r--x11-wm/fvwm/fvwm-2.5.7.ebuild136
3 files changed, 106 insertions, 39 deletions
diff --git a/x11-wm/fvwm/ChangeLog b/x11-wm/fvwm/ChangeLog
index 776da0f4e089..00e6f0c8232f 100644
--- a/x11-wm/fvwm/ChangeLog
+++ b/x11-wm/fvwm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/fvwm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.16 2003/07/30 21:55:48 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.17 2003/07/31 00:29:58 taviso Exp $
+
+ 31 Jul 2003; Tavis Ormandy <taviso@gentoo.org> fvwm-2.5.7.ebuild:
+ final fixes.
30 Jul 2003; Tavis Ormandy <taviso@gentoo.org> fvwm-2.5.7.ebuild:
Adding some real options, re-written the whole conf.
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index bf79d5d231dd..a32243705509 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,8 +1,8 @@
MD5 616d23339ff772ad286c142eee37efc8 fvwm-2.4.15.ebuild 1167
MD5 640cc8cf1c7b29a974fed717d4460794 fvwm-2.4.14.ebuild 1102
-MD5 7430517875f6cdf8bf7c5af53b46e7d3 fvwm-2.5.7.ebuild 2750
+MD5 5bb192b5a0b3ff8a88553b1d3a2b1e78 fvwm-2.5.7.ebuild 4915
MD5 9b68cbbbdaba95b23665ea98c695e57d fvwm-2.4.16.ebuild 1334
-MD5 7ffeb822c0eea195632cc4c2b7aa232b ChangeLog 2904
+MD5 34d6ab30543960abf312921a9f7a828d ChangeLog 2988
MD5 beaa1ad08ff661a32c25d1a51c879a8d metadata.xml 450
MD5 ccd8378d86941cb17669e64ca88949c1 fvwm-2.4.8.ebuild 1146
MD5 282c809ddaa59071830b6c8dd9b0a3a1 files/fvwm2 25
diff --git a/x11-wm/fvwm/fvwm-2.5.7.ebuild b/x11-wm/fvwm/fvwm-2.5.7.ebuild
index 4c61307da427..a1a84a882ecd 100644
--- a/x11-wm/fvwm/fvwm-2.5.7.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7.ebuild,v 1.8 2003/07/30 22:29:17 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7.ebuild,v 1.9 2003/07/31 00:29:58 taviso Exp $
inherit gnuconfig
-IUSE="readline gtk gnome rplay xinerama cjk perl nls png bidi"
+IUSE="readline gtk stroke gnome rplay xinerama cjk perl nls png bidi"
S=${WORKDIR}/${P}
DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
@@ -22,7 +22,7 @@ RDEPEND="readline? ( >=sys-libs/readline-4.1 )
perl? ( dev-lang/perl )
bidi? ( >=dev-libs/fribidi-0.10.4 )
png? ( media-libs/libpng )
- >=dev-libs/libstroke-0.4
+ stroke? ( >=dev-libs/libstroke-0.4 )
media-libs/fontconfig
dev-libs/expat"
DEPEND="${RDEPEND}
@@ -45,42 +45,77 @@ src_unpack() {
src_compile() {
local myconf="--libexecdir=/usr/lib --enable-xft"
- use readline \
- || myconf="${myconf} --without-readline-library"
+ # use readline in FvwmConsole.
+ if ! use readline; then
+ myconf="${myconf} --without-readline-library"
+ fi
- use gtk \
- || myconf="${myconf} --with-gtk-prefix=/var/empty --with-imlib-prefix=/var/empty"
-
- use gnome \
- && myconf="${myconf} --with-gnome" \
- || myconf="${myconf} --without-gnome"
+ # fvwm configure doesnt provide a way to disable gtk support if the
+ # required libraries are found, this hides them from the script.
+ if ! use gtk; then
+ myconf="${myconf} --with-gtk-prefix=${T} --with-imlib-prefix=${T}"
+ fi
- use rplay \
- || myconf="${myconf} --without-rplay-library"
-
- use perl \
- && myconf="${myconf} --enable-perllib" \
- || myconf="${myconf} --disable-perllib"
+ # link with the gnome libraries, for better integration with the gnome desktop.
+ if use gnome; then
+ myconf="${myconf} --with-gnome"
+ else
+ myconf="${myconf} --without-gnome"
+ fi
+
+ # rplay is a cool, but little used way of playing sounds over a network
+ # Fvwm support is pretty good.
+ if ! use rplay; then
+ myconf="${myconf} --without-rplay-library"
+ fi
+
+ # Install perl bindings for FvwmPerl.
+ if use perl; then
+ myconf="${myconf} --enable-perllib"
+ else
+ myconf="${myconf} --disable-perllib"
+ fi
- use xinerama \
- && myconf="${myconf} --enable-xinerama" \
- || myconf="${myconf} --disable-xinerama"
-
- use cjk \
- && myconf="${myconf} --enable-multibyte" \
- || myconf="${myconf} --disable-multibyte"
-
- use bidi \
- && myconf="${myconf} --enable-bidi" \
- || myconf="${myconf} --disable-bidi"
-
- use png \
- || myconf="${myconf} --without-png-library"
+ # xinerama support for those who have multi-headed machines.
+ if use xinerama; then
+ myconf="${myconf} --enable-xinerama"
+ else
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ # multibyte character support, chinese/japanese/korean/etc.
+ if use cjk; then
+ myconf="${myconf} --enable-multibyte"
+ else
+ myconf="${myconf} --disable-multibyte"
+ fi
+
+ # bidirectional writing support, eg hebrew
+ if use bidi; then
+ myconf="${myconf} --enable-bidi"
+ else
+ myconf="${myconf} --disable-bidi"
+ fi
+
+ # png image support (very nice in fvwm)
+ if ! use png; then
+ myconf="${myconf} --without-png-library"
+ fi
- use nls \
- && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
+ # native language support
+ if use nls; then
+ myconf="${myconf} --enable-nls"
+ else
+ myconf="${myconf} --disable-nls"
+ fi
+
+ # support for mouse gestures using libstroke (very very cool)
+ if ! use stroke; then
+ myconf="${myconf} --without-stroke-library"
+ fi
+ # Xft detection is broken in this release, the fix is in cvs
+ # which ive installed here, rerun automake to sort the problem.
einfo "Fixing Xft detection, please wait..."
( einfo " Running aclocal..."
aclocal
@@ -92,17 +127,46 @@ src_compile() {
autoreconf ) 2>/dev/null
einfo "Fixed."
+ # must specify PKG_CONFIG or Xft detection bombs.
econf ${myconf} PKG_CONFIG=/usr/bin/pkg-config || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
echo "#!/bin/bash" > fvwm2
- echo "/usr/bin/fvwm2" >> fvwm2
+ echo "exec /usr/bin/fvwm2" >> fvwm2
exeinto /etc/X11/Sessions
doexe fvwm2
+
+ dodoc AUTHORS ChangeLog COPYING README NEWS docs/ANNOUNCE docs/BUGS \
+ docs/COMMANDS docs/DEVELOPERS docs/FAQ docs/error_codes docs/TODO \
+ docs/fvwm.lsm
+
}
+pkg_postinst() {
+ local i
+ ewarn
+ ewarn "The Gentoo FVWM ebuild has been altered since the 2.4.x Branch."
+ ewarn "The following features that you did not request are now"
+ ewarn "controlled via USE flags, and not enabled automatically:"
+ use readline || ewarn " Readline support in FvwmConsole"
+ use stroke || ewarn " Mouse Gestures"
+ use xinerama || ewarn " Xinerama Support"
+ use cjk || ewarn " Multibyte Character Support"
+ use perl || ewarn " FVWM Perl bindings"
+ use nls || ewarn " Native Language Support"
+ use png || ewarn " PNG Support"
+ use bidi || ewarn " Bidirectional Language Support"
+ use rplay || ewarn " RPlay Support in FvwmEvent"
+ use gtk || ewarn " FvwmGTK (gtk+ support) (previously didnt honour USE flag)"
+ ewarn "If you require any of the features listed above, you should remerge"
+ ewarn "FVWM with the appropriate USE flags."
+ ewarn " $ emerge -pv fvwm"
+ ewarn
+
+ for ((i=0;i<5;i++)); do echo -ne '\a'; sleep 1; done
+}