summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-10-15 16:30:12 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-10-15 16:30:12 +0000
commit6f9ebba9d34bd9867ffa88e7806c9658b4217716 (patch)
treec6c0981fc298775f752763adb930df7fe5f482a0 /x11-wm
parentEAPI=2; HOMEPAGE tweak (bug #289211) (diff)
downloadgentoo-2-6f9ebba9d34bd9867ffa88e7806c9658b4217716.tar.gz
gentoo-2-6f9ebba9d34bd9867ffa88e7806c9658b4217716.tar.bz2
gentoo-2-6f9ebba9d34bd9867ffa88e7806c9658b4217716.zip
Version bump. Many bugfixes, 2 new plugins, Ported KDE4 window decorator to KDE 4.3. Fix bug #286431 thanks to Evert
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/ChangeLog9
-rw-r--r--x11-wm/compiz/compiz-0.8.4.ebuild152
-rw-r--r--x11-wm/compiz/files/compiz-manager2
3 files changed, 161 insertions, 2 deletions
diff --git a/x11-wm/compiz/ChangeLog b/x11-wm/compiz/ChangeLog
index d8e05737dc59..e07d47c5ddce 100644
--- a/x11-wm/compiz/ChangeLog
+++ b/x11-wm/compiz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/compiz
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.44 2009/08/29 12:28:11 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.45 2009/10/15 16:30:11 mrpouet Exp $
+
+*compiz-0.8.4 (15 Oct 2009)
+
+ 15 Oct 2009; Romain Perier <mrpouet@gentoo.org>
+ +compiz-0.8.4.ebuild, files/compiz-manager:
+ Version bump. Many bugfixes, 2 new plugins, Ported KDE4 window decorator
+ to KDE 4.3. Fix bug #286431 thanks to Evert.
*compiz-0.8.2-r3 (29 Aug 2009)
diff --git a/x11-wm/compiz/compiz-0.8.4.ebuild b/x11-wm/compiz/compiz-0.8.4.ebuild
new file mode 100644
index 000000000000..4fee4e87f024
--- /dev/null
+++ b/x11-wm/compiz/compiz-0.8.4.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.8.4.ebuild,v 1.1 2009/10/15 16:30:11 mrpouet Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="3D composite and windowmanager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+cairo dbus fuse gnome gtk kde kde3 +svg"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ media-libs/libpng
+ >=media-libs/mesa-6.5.1-r1
+ >=x11-base/xorg-server-1.1.1-r1
+ x11-libs/libX11[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libXrender-0.8.4
+ >=x11-libs/startup-notification-0.7
+ cairo? (
+ x11-libs/cairo[X]
+ )
+ dbus? ( >=sys-apps/dbus-1.0 )
+ fuse? ( sys-fs/fuse )
+ gnome? (
+ >=gnome-base/gnome-control-center-2.16.1:2
+ gnome-base/gnome-desktop
+ gnome-base/gconf:2
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.8.0:2
+ >=x11-libs/libwnck-2.18.3
+ x11-libs/pango
+ )
+ kde? (
+ || (
+ >=kde-base/kwin-4.2.0
+ kde-base/kwin:live
+ )
+ )
+ kde3? (
+ || ( kde-base/kwin:3.5
+ kde-base/kdebase:3.5
+ )
+ dev-libs/dbus-qt3-old
+ )
+ svg? (
+ >=gnome-base/librsvg-2.14.0:2
+ >=x11-libs/cairo-1.0
+ )
+"
+
+RDEPEND="${DEPEND}
+ x11-apps/mesa-progs
+ x11-apps/xvinfo"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ x11-proto/damageproto
+ x11-proto/xineramaproto"
+
+src_prepare() {
+
+ echo "gtk/gnome/compiz-wm.desktop.in" >> "${S}/po/POTFILES.skip"
+ echo "metadata/core.xml.in" >> "${S}/po/POTFILES.skip"
+
+ # Missing gconf flags, fix bug #282807
+ epatch "${FILESDIR}"/${PN}-0.8.2-gtk-gnome-missing-gconf-flags.patch
+
+ if ! use gnome; then
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-dependency-tracking \
+ --disable-gnome-keybindings \
+ --enable-librsvg \
+ --with-default-plugins \
+ $(use_enable cairo annotate) \
+ $(use_enable dbus) \
+ $(use_enable dbus dbus-glib) \
+ $(use_enable fuse) \
+ $(use_enable gnome) \
+ $(use_enable gnome gconf) \
+ $(use_enable gnome metacity) \
+ $(use_enable gtk) \
+ $(use_enable kde kde4) \
+ $(use_enable kde3 kde)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Install compiz-manager
+ dobin "${FILESDIR}/compiz-manager" || die "dobin failed"
+
+ # Add the full-path to lspci
+ sed -i "s#lspci#/usr/sbin/lspci#" "${D}/usr/bin/compiz-manager" || die "sed 1 failed"
+
+ # Fix the hardcoded lib paths
+ sed -i "s#/lib/#/$(get_libdir)/#g" "${D}/usr/bin/compiz-manager" || die "sed 2 failed"
+
+ # Create gentoo's config file
+ dodir /etc/xdg/compiz || die "dodir failed"
+
+ cat <<- EOF > "${D}/etc/xdg/compiz/compiz-manager"
+ COMPIZ_BIN_PATH="/usr/bin/"
+ PLUGIN_PATH="/usr/$(get_libdir)/compiz/"
+ LIBGL_NVIDIA="/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.so.1.2"
+ LIBGL_FGLRX="/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.so.1.2"
+ KWIN="$(type -p kwin)"
+ METACITY="$(type -p metacity)"
+ SKIP_CHECKS="yes"
+ EOF
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ insinto "/usr/share/applications"
+ doins "${FILESDIR}/compiz.desktop" || die "Failed to install compiz.desktop"
+}
+
+pkg_preinst() {
+ use gnome && gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+
+ ewarn "If you update to x11-wm/metacity-2.24 after you install ${P},"
+ ewarn "gtk-window-decorator will crash until you reinstall ${PN} again."
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
diff --git a/x11-wm/compiz/files/compiz-manager b/x11-wm/compiz/files/compiz-manager
index 3fbae21c0080..74d45da2590e 100644
--- a/x11-wm/compiz/files/compiz-manager
+++ b/x11-wm/compiz/files/compiz-manager
@@ -222,7 +222,7 @@ check_nvidia()
# Check if the max texture size is large enough compared to the resolution
check_texture_size()
{
- TEXTURE_LIMIT=$(glxinfo -l | grep GL_MAX_TEXTURE_SIZE | sed 's/.*=[^0-9]//g')
+ TEXTURE_LIMIT=$(glxinfo -l | grep -m1 GL_MAX_TEXTURE_SIZE | sed 's/.*=[^0-9]//g')
RESOLUTION=$(xdpyinfo | grep -i dimensions: | sed 's/[^0-9]*pixels.*(.*).*//' | sed 's/[^0-9x]*//')
VRES=$(echo $RESOLUTION | sed 's/.*x//')
HRES=$(echo $RESOLUTION | sed 's/x.*//')