summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-11-27 21:16:32 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-11-27 21:16:32 +0000
commita37265a9532be36d2ac11c49ec4752d3b003314a (patch)
tree51b91665e3c3c6a2cc7ffd89600db42364d8e561 /x11-wm
parentVersion bumped. (diff)
downloadgentoo-2-a37265a9532be36d2ac11c49ec4752d3b003314a.tar.gz
gentoo-2-a37265a9532be36d2ac11c49ec4752d3b003314a.tar.bz2
gentoo-2-a37265a9532be36d2ac11c49ec4752d3b003314a.zip
Version bump.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog8
-rw-r--r--x11-wm/afterstep/afterstep-2.2.4.ebuild141
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.2.43
3 files changed, 151 insertions, 1 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index 220819b21ef4..1fc5a06492fd 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/afterstep
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.63 2006/11/24 20:55:08 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.64 2006/11/27 21:16:32 kloeri Exp $
+
+*afterstep-2.2.4 (27 Nov 2006)
+
+ 27 Nov 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +afterstep-2.2.4.ebuild:
+ Version bump.
24 Nov 2006; Markus Rothe <corsair@gentoo.org> afterstep-2.2.2-r1.ebuild:
Stable on ppc64; bug #153726
diff --git a/x11-wm/afterstep/afterstep-2.2.4.ebuild b/x11-wm/afterstep/afterstep-2.2.4.ebuild
new file mode 100644
index 000000000000..056799daf852
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.2.4.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.4.ebuild,v 1.1 2006/11/27 21:16:32 kloeri Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+
+LICENSE="AFTERSTEP"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gif jpeg mmx nls png tiff xinerama"
+
+RDEPEND="virtual/libc
+ media-libs/freetype
+ debug? ( !hppa? ( !ppc? ( dev-util/efence ) ) )
+ png? ( >=media-libs/libpng-1.2.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )"
+
+S="${WORKDIR}/AfterStep-${PV}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/no-alternatives.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+ --enable-audit --enable-trace --enable-trace-x"
+
+ if ! use ppc && use debug ; then
+ myconf="${myconf} --with-libefence"
+ fi
+
+ #implied intent of debug means you need the frame pointers.
+ use debug && filter-flags -fomit-frame-pointer
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --with-ungif=no - Use giflib instead of libungif
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+
+ econf \
+ $(use_enable nls i18n) \
+ $(use_enable mmx mmx-optimization) \
+ $(use_enable xinerama) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with gif) \
+ $(use_with tiff) \
+ --with-helpcommand="xterm -e man" \
+ --with-ungif=no \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # see bug #31541
+ dodir /usr/share/gnome/wm-properties
+
+ # afterstep tries to detect the current resolution
+ # for documentation generation, causing access violations
+ # for the video device. bug #87356
+ unset DISPLAY
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ # This fixes a bug with shared libraries
+ rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
+ cp -pPR ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterConf/libAfterConf.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterStep/libAfterStep.so* ${D}/usr/lib
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm ${D}/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -pPR ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ newins ${S}/AfterStep.desktop.final AfterStep.desktop
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/afterstep
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use AfterStep issue the following commands:"
+ einfo "mv ~/.xinitrc ~/xinitrc.old"
+ einfo "echo afterstep > ~/.xinitrc"
+ echo
+ einfo "If you like AfterStep please vote for it at"
+ einfo "http://www.PLiG.org/xwinman/vote.html !"
+ echo
+}
+
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.2.4 b/x11-wm/afterstep/files/digest-afterstep-2.2.4
new file mode 100644
index 000000000000..03cff0cd8c31
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-2.2.4
@@ -0,0 +1,3 @@
+MD5 a382ad2fd2947d26010d1ec5f6a80392 AfterStep-2.2.4.tar.bz2 5707951
+RMD160 74ab7c74afce8d5d669a1520a3c02f04882e05b9 AfterStep-2.2.4.tar.bz2 5707951
+SHA256 e1787184faaee583435730666ef3dd1c221ced493ccd9ba0a06f94ac5e5b05ec AfterStep-2.2.4.tar.bz2 5707951