summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-03 10:50:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-03 10:50:32 +0000
commitad21ecedacc86c731f941581a9d60d0da1e00780 (patch)
tree10d22f32447c58a7c075ede16e61420f32e1f24c /x11-wm
parentInvalid header. Define RDEPEND. (diff)
downloadgentoo-2-ad21ecedacc86c731f941581a9d60d0da1e00780.tar.gz
gentoo-2-ad21ecedacc86c731f941581a9d60d0da1e00780.tar.bz2
gentoo-2-ad21ecedacc86c731f941581a9d60d0da1e00780.zip
Define RDEPEND
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/matchbox-window-manager/matchbox-window-manager-1.1.ebuild56
-rw-r--r--x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild7
2 files changed, 4 insertions, 59 deletions
diff --git a/x11-wm/matchbox-window-manager/matchbox-window-manager-1.1.ebuild b/x11-wm/matchbox-window-manager/matchbox-window-manager-1.1.ebuild
deleted file mode 100644
index f20c3cf1d670..000000000000
--- a/x11-wm/matchbox-window-manager/matchbox-window-manager-1.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2006-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/matchbox-window-manager-1.1.ebuild,v 1.4 2009/03/14 03:52:45 solar Exp $
-
-inherit eutils versionator gnome2
-
-DESCRIPTION="Light weight WM designed for use on PDA computers"
-HOMEPAGE="http://matchbox-project.org/"
-SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
-SLOT="0"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="debug expat gnome session startup-notification xcomposite"
-
-DEPEND=">=x11-libs/libmatchbox-1.5
- expat? ( dev-libs/expat )
- gnome? ( gnome-base/gconf )
- startup-notification? ( x11-libs/startup-notification )
- session? ( x11-libs/libSM )
- xcomposite? ( x11-libs/libXcomposite
- x11-libs/libXdamage )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Allows to build with USE=-png
- epatch "${FILESDIR}"/${PN}-1.0-use-nopng.patch
-}
-
-src_compile() {
- econf --enable-keyboard \
- --enable-ping-protocol \
- --enable-xrm \
- $(use_enable debug) \
- $(use_enable session) \
- $(use_enable expat) \
- $(use_enable gnome gconf) \
- $(use_enable startup-notification) \
- $(use_enable xcomposite composite) \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- # we must delay gconf schema installation due to sandbox
- export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
- make DESTDIR="${D}" install || die "Installation failed"
- unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
-
- gnome2_gconf_install
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README
-}
diff --git a/x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild b/x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild
index af6343900d63..25dfb00cbe04 100644
--- a/x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild
+++ b/x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild,v 1.6 2009/03/14 03:52:45 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-window-manager/matchbox-window-manager-1.2.ebuild,v 1.7 2009/08/03 10:50:32 ssuominen Exp $
inherit eutils versionator gnome2
@@ -13,13 +13,14 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
IUSE="debug expat gnome session startup-notification xcomposite"
-DEPEND=">=x11-libs/libmatchbox-1.5
+RDEPEND=">=x11-libs/libmatchbox-1.5
expat? ( dev-libs/expat )
gnome? ( gnome-base/gconf )
startup-notification? ( x11-libs/startup-notification )
session? ( x11-libs/libSM )
xcomposite? ( x11-libs/libXcomposite
- x11-libs/libXdamage )"
+ x11-libs/libXdamage )"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}