summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2007-01-17 00:23:40 +0000
committerDavid Shakaryan <omp@gentoo.org>2007-01-17 00:23:40 +0000
commitb5f7a944db99225709b9a26929473799efccc21f (patch)
tree850218230ea173e7a6a600c05ea7b370b4e414b4 /x11-wm
parentRemove unneeded patch. (diff)
downloadgentoo-2-b5f7a944db99225709b9a26929473799efccc21f.tar.gz
gentoo-2-b5f7a944db99225709b9a26929473799efccc21f.tar.bz2
gentoo-2-b5f7a944db99225709b9a26929473799efccc21f.zip
Fix sed expression. (bug #160328)
(Portage version: 2.1.2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/wmii/ChangeLog7
-rw-r--r--x11-wm/wmii/wmii-3.5.1.ebuild18
2 files changed, 14 insertions, 11 deletions
diff --git a/x11-wm/wmii/ChangeLog b/x11-wm/wmii/ChangeLog
index 47117274770f..e0c79b4fb393 100644
--- a/x11-wm/wmii/ChangeLog
+++ b/x11-wm/wmii/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/wmii
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/ChangeLog,v 1.13 2006/12/28 07:32:42 omp Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/ChangeLog,v 1.14 2007/01/17 00:23:40 omp Exp $
+
+ 17 Jan 2007; David Shakaryan <omp@gentoo.org> wmii-3.5.1.ebuild:
+ Fix sed expression. (bug #160328)
28 Dec 2006; David Shakaryan <omp@gentoo.org> files/wmii.desktop,
metadata.xml, +wmii-3.5.1.ebuild:
diff --git a/x11-wm/wmii/wmii-3.5.1.ebuild b/x11-wm/wmii/wmii-3.5.1.ebuild
index d0aae3672b2f..2841ca619b02 100644
--- a/x11-wm/wmii/wmii-3.5.1.ebuild
+++ b/x11-wm/wmii/wmii-3.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/wmii-3.5.1.ebuild,v 1.1 2006/12/28 07:32:42 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/wmii-3.5.1.ebuild,v 1.2 2007/01/17 00:23:40 omp Exp $
inherit toolchain-funcs
@@ -23,13 +23,13 @@ src_unpack() {
cd "${S}"
sed -i \
- -e "/^PREFIX/s/=.*/= \/usr/" \
- -e "/^CONFPREFIX/s/=.*/= \/etc/" \
- -e "/^X11INC/s/=.*/= \/usr\/include/" \
- -e "/^X11LIB/s/=.*/= \/usr\/lib/" \
- -e "/^CFLAGS/s/= -Os/+=/" \
- -e "/^LDFLAGS/s/=/+=/" \
- -e "/^CC/s/=.*/= $(tc-getCC)/" \
+ -e "/^PREFIX/s|=.*|= /usr|" \
+ -e "/^CONFPREFIX/s|=.*|= /etc|" \
+ -e "/^X11INC/s|=.*|= /usr/include|" \
+ -e "/^X11LIB/s|=.*|= /usr/lib|" \
+ -e "/^CFLAGS/s|= -Os|+=|" \
+ -e "/^LDFLAGS/s|=|+=|" \
+ -e "/^CC/s|=.*|= $(tc-getCC)|" \
config.mk || die "sed failed"
}