summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-12-31 16:44:58 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-12-31 16:44:58 +0000
commitf5c5dca7cbb9ea260841c4dd23d8fb95ba7c7446 (patch)
tree6c4800a92f7c0637fee7340fe78147b4c9f1cd2d /x11-wm
parentVersion bump (diff)
downloadgentoo-2-f5c5dca7cbb9ea260841c4dd23d8fb95ba7c7446.tar.gz
gentoo-2-f5c5dca7cbb9ea260841c4dd23d8fb95ba7c7446.tar.bz2
gentoo-2-f5c5dca7cbb9ea260841c4dd23d8fb95ba7c7446.zip
Fixed the hardcoded /lib path in compiz-manager. Fixes bug #253246.
(Portage version: 2.2_rc19/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/ChangeLog8
-rw-r--r--x11-wm/compiz/compiz-0.7.8-r2.ebuild146
-rw-r--r--x11-wm/compiz/compiz-0.7.8.ebuild5
-rw-r--r--x11-wm/compiz/files/compiz-manager19
4 files changed, 166 insertions, 12 deletions
diff --git a/x11-wm/compiz/ChangeLog b/x11-wm/compiz/ChangeLog
index 6908928b626d..8bda8b63475d 100644
--- a/x11-wm/compiz/ChangeLog
+++ b/x11-wm/compiz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/compiz
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.35 2008/12/03 02:18:35 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/ChangeLog,v 1.36 2008/12/31 16:44:58 jmbsvicetto Exp $
+
+*compiz-0.7.8-r2 (31 Dec 2008)
+
+ 31 Dec 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ files/compiz-manager, compiz-0.7.8.ebuild, +compiz-0.7.8-r2.ebuild:
+ Fixed the hardcoded /lib path in compiz-manager. Fixes bug #253246.
03 Dec 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
compiz-0.7.8-r1.ebuild:
diff --git a/x11-wm/compiz/compiz-0.7.8-r2.ebuild b/x11-wm/compiz/compiz-0.7.8-r2.ebuild
new file mode 100644
index 000000000000..aac7ef6a54fb
--- /dev/null
+++ b/x11-wm/compiz/compiz-0.7.8-r2.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.7.8-r2.ebuild,v 1.1 2008/12/31 16:44:58 jmbsvicetto Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2-utils multilib
+
+DESCRIPTION="3D composite and windowmanager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://xorg.freedesktop.org/archive/individual/app/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cairo dbus fuse gnome gtk kde kde4 +svg"
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=media-libs/glitz-0.5.6
+ media-libs/libpng
+ >=media-libs/mesa-6.5.1-r1
+ >=x11-base/xorg-server-1.1.1-r1
+ x11-libs/libX11[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libXrender-0.8.4
+ >=x11-libs/startup-notification-0.7
+ cairo? (
+ x11-libs/cairo[X]
+ )
+ dbus? ( >=sys-apps/dbus-1.0 )
+ fuse? ( sys-fs/fuse )
+ gnome? (
+ >=gnome-base/gnome-control-center-2.16.1:2
+ gnome-base/gnome-desktop
+ gnome-base/gconf:2
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.8.0:2
+ >=x11-libs/libwnck-2.18.3
+ x11-libs/pango
+ )
+ kde? (
+ || ( kde-base/kwin:3.5
+ kde-base/kdebase:3.5
+ )
+ dev-libs/dbus-qt3-old
+ )
+ kde4? (
+ || (
+ kde-base/kwin:4.2
+ kde-base/kwin:live
+ )
+ )
+ svg? (
+ >=gnome-base/librsvg-2.14.0:2
+ >=x11-libs/cairo-1.0
+ )
+"
+
+RDEPEND="${DEPEND}
+ x11-apps/mesa-progs
+ x11-apps/xvinfo"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ x11-proto/damageproto
+ x11-proto/xineramaproto"
+
+src_prepare() {
+
+ use kde4 && epatch "${FILESDIR}/${P}-framesvg.patch"
+ use gnome || {
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+ ln -s "${ROOT}"/usr/share/aclocal/gconf-2.m4 acinclude.m4
+
+ # required to apply the above patch
+ intltoolize --copy --force || die "intltoolize failed"
+ eautoreconf || die "eautoreconf failed"
+ }
+}
+
+src_configure() {
+ econf \
+ --disable-gnome-keybindings \
+ --enable-librsvg \
+ --with-default-plugins \
+ $(use_enable cairo annotate) \
+ $(use_enable dbus) \
+ $(use_enable dbus dbus-glib) \
+ $(use_enable fuse) \
+ $(use_enable gnome) \
+ $(use_enable gnome gconf) \
+ $(use_enable gnome metacity) \
+ $(use_enable gtk) \
+ $(use_enable kde) \
+ $(use_enable kde4) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Install compiz-manager
+ dobin "${FILESDIR}/compiz-manager" || die "dobin failed"
+
+ # Add the full-path to lspci
+ sed -i "s#lspci#/usr/sbin/lspci#" "${D}/usr/bin/compiz-manager"
+
+ # Fix the hardcoded lib paths
+ sed -i "s#/lib/#/$(get_libdir)/#g" "${D}/usr/bin/compiz-manager"
+
+ # Create gentoo's config file
+ dodir /etc/xdg/compiz
+
+ cat <<- EOF > "${D}/etc/xdg/compiz/compiz-manager"
+ COMPIZ_BIN_PATH="/usr/bin/"
+ PLUGIN_PATH="/usr/$(get_libdir)/compiz/"
+ LIBGL_NVIDIA="/usr/$(get_libdir)/opengl/xorg-x11/libGL.so.1.2"
+ LIBGL_FGLRX="/usr/$(get_libdir)/opengl/xorg-x11/libGL.so.1.2"
+ KWIN="$(type -p kwin)"
+ METACITY="$(type -p metacity)"
+ SKIP_CHECKS="yes"
+ EOF
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+
+ ewarn "If you update to x11-wm/metacity-2.24 after you install ${P},"
+ ewarn "gtk-window-decorator will crash until you reinstall ${PN} again."
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
diff --git a/x11-wm/compiz/compiz-0.7.8.ebuild b/x11-wm/compiz/compiz-0.7.8.ebuild
index 3c7361a232c7..a82e6c813ba7 100644
--- a/x11-wm/compiz/compiz-0.7.8.ebuild
+++ b/x11-wm/compiz/compiz-0.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.7.8.ebuild,v 1.4 2008/12/02 16:46:31 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/compiz/compiz-0.7.8.ebuild,v 1.5 2008/12/31 16:44:58 jmbsvicetto Exp $
EAPI="2"
@@ -109,6 +109,9 @@ src_install() {
# Add the full-path to lspci
sed -i "s#lspci#/usr/sbin/lspci#" "${D}/usr/bin/compiz-manager"
+ # Fix the hardcoded lib paths
+ sed -i "s#/lib/#/$(get_libdir)/#g" "${D}/usr/bin/compiz-manager"
+
# Create gentoo's config file
dodir /etc/xdg/compiz
diff --git a/x11-wm/compiz/files/compiz-manager b/x11-wm/compiz/files/compiz-manager
index 3fbae21c0080..6e8fa5796474 100644
--- a/x11-wm/compiz/files/compiz-manager
+++ b/x11-wm/compiz/files/compiz-manager
@@ -1,6 +1,6 @@
#!/bin/sh
# Compiz Manager wrapper script
-#
+#
# Copyright (c) 2007 Kristian Lyngstøl <kristian@bohemians.org>
#
# This program is free software; you can redistribute it and/or modify
@@ -24,15 +24,15 @@
# Much of this code is based on Beryl code, also licensed under the GPL.
# This script will detect what options we need to pass to compiz to get it
# started, and start a default plugin and possibly window decorator.
-#
+#
COMPIZ_BIN_PATH="/usr/bin/" # For window decorators and compiz
-PLUGIN_PATH="/usr/lib/compiz/"
+PLUGIN_PATH="/usr/lib/compiz/"
GLXINFO="/usr/bin/glxinfo"
KWIN="/usr/bin/kwin"
METACITY="/usr/bin/metacity"
-COMPIZ_NAME="compiz" # Final name for compiz (compiz.real)
+COMPIZ_NAME="compiz" # Final name for compiz (compiz.real)
# For Xgl LD_PRELOAD
LIBGL_NVIDIA="/usr/lib/nvidia/libGL.so.1.2.xlibmesa"
@@ -53,7 +53,7 @@ FALLBACKWM_OPTIONS="--replace $@"
# Driver whitelist
WHITELIST="nvidia intel ati radeon i810"
-# blacklist based on the pci ids
+# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
T=" 1002:5954 1002:5854 1002:5955" # ati rs480
T="$T 1002:4153" # ATI Rv350
@@ -122,10 +122,10 @@ check_fbconfig()
{
verbose "Checking for FBConfig: "
if [ "$INDIRECT" = "yes" ]; then
- $GLXINFO -i | grep -q GLX.*fbconfig
+ $GLXINFO -i | grep -q GLX.*fbconfig
FB=$?
else
- $GLXINFO | grep -q GLX.*fbconfig
+ $GLXINFO | grep -q GLX.*fbconfig
FB=$?
fi
@@ -250,7 +250,7 @@ running_under_whitelisted_driver()
fi
for DRV in ${WHITELIST}; do
if egrep -q "Loading ${XORG_DRIVER_PATH}${DRV}_drv\.so" $LOG &&
- ! egrep -q "Unloading ${XORG_DRIVER_PATH}${DRV}_drv\.so" $LOG;
+ ! egrep -q "Unloading ${XORG_DRIVER_PATH}${DRV}_drv\.so" $LOG;
then
return 0
fi
@@ -341,7 +341,7 @@ if ! check_xgl; then
if ! running_under_whitelisted_driver || have_blacklisted_pciid; then
abort_with_fallback_wm
fi
- # check if we have the required bits to run compiz and if not,
+ # check if we have the required bits to run compiz and if not,
# fallback
if ! check_tfp || ! check_npot_texture || ! check_composite || ! check_texture_size; then
abort_with_fallback_wm
@@ -381,4 +381,3 @@ elif [ -x ${COMPIZ_BIN_PATH}kde-window-decorator ] && [ -n "$KDE_FULL_SESSION" ]
fi
${COMPIZ_BIN_PATH}${COMPIZ_NAME} $COMPIZ_OPTIONS "$@" $COMPIZ_PLUGINS || exec $FALLBACKWM $FALLBACKWM_OPTIONS
-