summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-16 16:51:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-16 16:51:04 +0000
commit37c33a0df347e6da0f6814af809abd88cdcda68b (patch)
treedbc5a4a90218d3b1b32b5d45367d75777231eb2f /xfce-base/exo
parentRestrict Jython ABIs. (diff)
downloadgentoo-2-37c33a0df347e6da0f6814af809abd88cdcda68b.tar.gz
gentoo-2-37c33a0df347e6da0f6814af809abd88cdcda68b.tar.bz2
gentoo-2-37c33a0df347e6da0f6814af809abd88cdcda68b.zip
Version bump.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.6.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 1df2109de5c4..cf3c439cbedc 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.47 2011/01/02 15:11:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.48 2011/01/16 16:51:04 ssuominen Exp $
+
+*exo-0.6.0 (16 Jan 2011)
+
+ 16 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +exo-0.6.0.ebuild:
+ Version bump.
*exo-0.5.6 (02 Jan 2011)
diff --git a/xfce-base/exo/exo-0.6.0.ebuild b/xfce-base/exo/exo-0.6.0.ebuild
new file mode 100644
index 000000000000..16641ffb7970
--- /dev/null
+++ b/xfce-base/exo/exo-0.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.0.ebuild,v 1.1 2011/01/16 16:51:04 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+
+inherit python xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo/"
+SRC_URI="mirror://xfce/src/xfce/exo/0.6/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ python? ( >=dev-python/pygtk-2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable python)
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+
+ xfconf_src_prepare
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ use python && python_mod_optimize exo-0.6 pyexo.py
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ use python && python_mod_cleanup exo-0.6 pyexo.py
+}