summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-01 15:10:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-01 15:10:21 +0000
commit77c8fd6326c7e2a1045ae4bf6c7361276cba7ced (patch)
treeff950cf605dfc9a6a9a54b96dd76605b1b16f9f1 /xfce-base/exo
parentStable for amd64, wrt bug #401985 (diff)
downloadgentoo-2-77c8fd6326c7e2a1045ae4bf6c7361276cba7ced.tar.gz
gentoo-2-77c8fd6326c7e2a1045ae4bf6c7361276cba7ced.tar.bz2
gentoo-2-77c8fd6326c7e2a1045ae4bf6c7361276cba7ced.zip
Backport upstream patch to include Chromium (or Google Chrome) in the preferred browsers list wrt #388853 by Michael Mol and Paweł Hajdan, Jr.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog9
-rw-r--r--xfce-base/exo/exo-0.6.2-r1.ebuild64
-rw-r--r--xfce-base/exo/files/exo-0.6.x-chromium.patch37
3 files changed, 109 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 1e613905c4af..f0b99a08e1bc 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.68 2012/02/20 20:32:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.69 2012/03/01 15:10:21 ssuominen Exp $
+
+*exo-0.6.2-r1 (01 Mar 2012)
+
+ 01 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +exo-0.6.2-r1.ebuild,
+ +files/exo-0.6.x-chromium.patch:
+ Backport upstream patch to include Chromium (or Google Chrome) in the
+ preferred browsers list wrt #388853 by Michael Mol and Paweł Hajdan, Jr.
*exo-0.7.1 (20 Feb 2012)
diff --git a/xfce-base/exo/exo-0.6.2-r1.ebuild b/xfce-base/exo/exo-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..166113c2bc93
--- /dev/null
+++ b/xfce-base/exo/exo-0.6.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.2-r1.ebuild,v 1.1 2012/03/01 15:10:21 ssuominen Exp $
+
+EAPI=4
+PYTHON_DEPEND="python? 2:2.6"
+EAUTORECONF=yes
+inherit python xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.18
+ dev-perl/URI
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ python? ( >=dev-python/pygtk-2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ PATCHES=( "${FILESDIR}"/${PN}-0.6.x-chromium.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-static
+ $(use_enable python)
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}
+
+src_prepare() {
+ >py-compile
+ xfconf_src_prepare
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ use python && python_mod_optimize exo-0.6 pyexo.py
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ use python && python_mod_cleanup exo-0.6 pyexo.py
+}
diff --git a/xfce-base/exo/files/exo-0.6.x-chromium.patch b/xfce-base/exo/files/exo-0.6.x-chromium.patch
new file mode 100644
index 000000000000..d43205396816
--- /dev/null
+++ b/xfce-base/exo/files/exo-0.6.x-chromium.patch
@@ -0,0 +1,37 @@
+From a8bd98bfda679b52b92615984ec3129b1b9469da Mon Sep 17 00:00:00 2001
+From: Nick Schermer <nick@xfce.org>
+Date: Fri, 10 Feb 2012 21:26:55 +0000
+Subject: Add preferred app helper for Chromium (bug #8398).
+
+---
+diff --git a/exo-helper/helpers/Makefile.am b/exo-helper/helpers/Makefile.am
+index 052ed2f..b9d292a 100644
+--- a/exo-helper/helpers/Makefile.am
++++ b/exo-helper/helpers/Makefile.am
+@@ -8,6 +8,7 @@ desktop_in_in_files = \
+ Thunar.desktop.in.in \
+ aterm.desktop.in.in \
+ balsa.desktop.in.in \
++ chromium.desktop.in.in \
+ debian-sensible-browser.desktop.in.in \
+ debian-x-terminal-emulator.desktop.in.in \
+ encompass.desktop.in.in \
+diff --git a/exo-helper/helpers/chromium.desktop.in.in b/exo-helper/helpers/chromium.desktop.in.in
+new file mode 100644
+index 0000000..a9edf06
+--- a/dev/null
++++ b/exo-helper/helpers/chromium.desktop.in.in
+@@ -0,0 +1,11 @@
++
++[Desktop Entry]
++Version=1.0
++Icon=chromium
++Type=X-XFCE-Helper
++_Name=Chromium
++StartupNotify=true
++X-XFCE-Binaries=chromium;google-chrome;
++X-XFCE-Category=WebBrowser
++X-XFCE-Commands=%B;
++X-XFCE-CommandsWithParameter=%B "%s";
+--
+cgit v0.9.0.2