summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2004-10-04 18:12:25 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2004-10-04 18:12:25 +0000
commit6068be2e38ac3b12a23f734526605ca1def3efad (patch)
treeb1d3a697a84cf19fa3981a8517ff4e8ae78fffa4 /xfce-base/libxfcegui4/libxfcegui4-4.1.90.ebuild
parentremove !arch? in *DEPEND, use.mask instead. Stable on x86 (Manifest recommit) (diff)
downloadgentoo-2-6068be2e38ac3b12a23f734526605ca1def3efad.tar.gz
gentoo-2-6068be2e38ac3b12a23f734526605ca1def3efad.tar.bz2
gentoo-2-6068be2e38ac3b12a23f734526605ca1def3efad.zip
Beta version of new 4.2 release. Contains too numerous improvements to list.
Diffstat (limited to 'xfce-base/libxfcegui4/libxfcegui4-4.1.90.ebuild')
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.1.90.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.1.90.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.1.90.ebuild
new file mode 100644
index 000000000000..5bcfc8068bc4
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.1.90.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+IUSE="xinerama"
+DESCRIPTION="Libraries for Xfce 4"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+HOMEPAGE="http://xfce.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa ~mips"
+
+RDEPEND="virtual/x11
+ >=x11-libs/gtk+-2.2*
+ dev-libs/libxml2
+ x11-libs/startup-notification
+ =xfce-base/libxfce4util-4.1.90"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !<xfce-base/libxfcegui4-4.1.90"
+
+src_compile() {
+ econf \
+ `use_enable xinerama` || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog* AUTHORS README*
+}