summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2005-10-06 04:32:04 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2005-10-06 04:32:04 +0000
commit5a49ff837561db7fa461205f013c252a1013149c (patch)
treea6ed23a307be4ab0b41fcf20dae52e7ec3d7ff40 /xfce-base/libxfcegui4
parentNew release: 2.12.1.1 (diff)
downloadgentoo-2-5a49ff837561db7fa461205f013c252a1013149c.tar.gz
gentoo-2-5a49ff837561db7fa461205f013c252a1013149c.tar.bz2
gentoo-2-5a49ff837561db7fa461205f013c252a1013149c.zip
Patch to fix problem with taskbar and gtk+-2.8, closes bug #102912.
(Portage version: 1.589-cvs)
Diffstat (limited to 'xfce-base/libxfcegui4')
-rw-r--r--xfce-base/libxfcegui4/ChangeLog8
-rw-r--r--xfce-base/libxfcegui4/files/digest-libxfcegui4-4.2.2-r11
-rw-r--r--xfce-base/libxfcegui4/files/taskbar-gtk-2.8.patch20
-rw-r--r--xfce-base/libxfcegui4/libxfcegui4-4.2.2-r1.ebuild18
4 files changed, 46 insertions, 1 deletions
diff --git a/xfce-base/libxfcegui4/ChangeLog b/xfce-base/libxfcegui4/ChangeLog
index 5df713c049c9..35bc3870ea90 100644
--- a/xfce-base/libxfcegui4/ChangeLog
+++ b/xfce-base/libxfcegui4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfcegui4
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/ChangeLog,v 1.54 2005/07/12 12:42:07 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/ChangeLog,v 1.55 2005/10/06 04:32:04 bcowan Exp $
+
+*libxfcegui4-4.2.2-r1 (06 Oct 2005)
+
+ 06 Oct 2005; Brad Cowan <bcowan@gentoo.org> +files/taskbar-gtk-2.8.patch,
+ +libxfcegui4-4.2.2-r1.ebuild:
+ Patch to fix problems with taskbar and gtk+-2.8 fixes bug #102912.
12 Jul 2005; Simon Stelling <blubb@gentoo.org> libxfcegui4-4.2.2.ebuild:
stable on amd64
diff --git a/xfce-base/libxfcegui4/files/digest-libxfcegui4-4.2.2-r1 b/xfce-base/libxfcegui4/files/digest-libxfcegui4-4.2.2-r1
new file mode 100644
index 000000000000..aea7028a85bd
--- /dev/null
+++ b/xfce-base/libxfcegui4/files/digest-libxfcegui4-4.2.2-r1
@@ -0,0 +1 @@
+MD5 e88d6e8379eae60cee6dd6122bf3ae59 libxfcegui4-4.2.2.tar.gz 853844
diff --git a/xfce-base/libxfcegui4/files/taskbar-gtk-2.8.patch b/xfce-base/libxfcegui4/files/taskbar-gtk-2.8.patch
new file mode 100644
index 000000000000..9e792dcd6f78
--- /dev/null
+++ b/xfce-base/libxfcegui4/files/taskbar-gtk-2.8.patch
@@ -0,0 +1,20 @@
+--- libxfcegui4-4.2.2/libxfcegui4/netk-tasklist.c 2005-05-15 09:53:29.000000000 +0200
++++ libxfcegui4-4.2.2.new/libxfcegui4/netk-tasklist.c 2005-07-31 16:19:44.000000000 +0200
+@@ -2238,8 +2238,15 @@
+ if (task->tasklist->priv->show_label) {
+ task->label = gtk_label_new (text);
+ gtk_widget_show (task->label);
+- gtk_table_attach (GTK_TABLE (table),
++ if(GTK_CHECK_VERSION(2, 7, 0)){
++ gtk_label_set_ellipsize(task->label, PANGO_ELLIPSIZE_END);
++ gtk_table_attach (GTK_TABLE (table),
++ task->label, 1, 2, 0, 1, GTK_EXPAND|GTK_FILL|GTK_SHRINK, GTK_EXPAND, 0, 0);
++ }
++ else{
++ gtk_table_attach (GTK_TABLE (table),
+ task->label, 1, 2, 0, 1, GTK_EXPAND, GTK_EXPAND, 0, 0);
++ }
+ }
+
+ gtk_container_add (GTK_CONTAINER (task->button), table);
+
diff --git a/xfce-base/libxfcegui4/libxfcegui4-4.2.2-r1.ebuild b/xfce-base/libxfcegui4/libxfcegui4-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..8bab9155960a
--- /dev/null
+++ b/xfce-base/libxfcegui4/libxfcegui4-4.2.2-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfcegui4/libxfcegui4-4.2.2-r1.ebuild,v 1.1 2005/10/06 04:32:04 bcowan Exp $
+
+DESCRIPTION="Libraries for Xfce 4"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~xfce-base/libxfce4util-${PV}"
+
+inherit xfce4 eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/taskbar-gtk-2.8.patch
+}