summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-10-30 22:03:16 +0000
committerChristoph Mende <angelos@gentoo.org>2008-10-30 22:03:16 +0000
commit1c6ac349c49edea09c03dafcd669b5b229b4c839 (patch)
tree0521f475f01270533f2bc803c15fc4d92e422815 /xfce-base/xfce-utils
parentXfce-4.4.3 bump (diff)
downloadgentoo-2-1c6ac349c49edea09c03dafcd669b5b229b4c839.tar.gz
gentoo-2-1c6ac349c49edea09c03dafcd669b5b229b4c839.tar.bz2
gentoo-2-1c6ac349c49edea09c03dafcd669b5b229b4c839.zip
Xfce-4.4.3 bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.28-rc2 x86_64)
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog8
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.4.3.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 264e7839e99d..be10fdeddd95 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.124 2008/09/24 15:43:07 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.125 2008/10/30 22:03:16 angelos Exp $
+
+*xfce-utils-4.4.3 (30 Oct 2008)
+
+ 30 Oct 2008; Christoph Mende <angelos@gentoo.org>
+ +xfce-utils-4.4.3.ebuild:
+ Xfce-4.4.3 bump
24 Sep 2008; Christoph Mende <angelos@gentoo.org> metadata.xml,
xfce-utils-4.4.2-r1.ebuild:
diff --git a/xfce-base/xfce-utils/xfce-utils-4.4.3.ebuild b/xfce-base/xfce-utils/xfce-utils-4.4.3.ebuild
new file mode 100644
index 000000000000..c046362019e7
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.4.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.4.3.ebuild,v 1.1 2008/10/30 22:03:16 angelos Exp $
+
+EAPI=1
+
+inherit eutils xfce44
+
+XFCE_VERSION=4.4.3
+
+xfce44
+xfce44_core_package
+
+DESCRIPTION="Collection of utils"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug +lock"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libX11
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfcegui4-${XFCE_MASTER_VERSION}
+ >=xfce-base/libxfce4mcs-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
+ dbus? ( dev-libs/dbus-glib )
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore ) )"
+
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable dbus) --enable-gdm --with-vendor-info=Gentoo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.4.2-nolisten-tcp.patch
+}
+
+src_install() {
+ xfce44_src_install
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}"/Gentoo
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"