summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-02 15:25:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-02 15:25:10 +0000
commit239ca44c62c9ac52f2f21dc8c9122aa5d4fd6911 (patch)
tree5844a9514d922d833f2e4bfd71bc1e20beb0da6c /xfce-base/xfconf
parentStable on alpha, bug #347223 (diff)
downloadgentoo-2-239ca44c62c9ac52f2f21dc8c9122aa5d4fd6911.tar.gz
gentoo-2-239ca44c62c9ac52f2f21dc8c9122aa5d4fd6911.tar.bz2
gentoo-2-239ca44c62c9ac52f2f21dc8c9122aa5d4fd6911.zip
Version bump.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/ChangeLog9
-rw-r--r--xfce-base/xfconf/xfconf-4.7.5.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index 1235aaf2a206..e3cf45c6439f 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfconf
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.43 2010/12/03 21:35:48 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.44 2011/01/02 15:25:10 ssuominen Exp $
+
+*xfconf-4.7.5 (02 Jan 2011)
+
+ 02 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfconf-4.7.5.ebuild:
+ Version bump.
*xfconf-4.7.4 (03 Dec 2010)
diff --git a/xfce-base/xfconf/xfconf-4.7.5.ebuild b/xfce-base/xfconf/xfconf-4.7.5.ebuild
new file mode 100644
index 000000000000..b2d58c612114
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.7.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.7.5.ebuild,v 1.1 2011/01/02 15:25:10 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's configuration storage system"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/xfconf/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="debug perl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.18:2
+ >=xfce-base/libxfce4util-4.6
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable perl perl-bindings)
+ $(xfconf_use_debug)
+ $(use_enable debug checks)
+ --with-perl-options=INSTALLDIRS=vendor
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}