summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-03 21:35:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-03 21:35:48 +0000
commit2c5c169af0b3fc3e226b8ea0f32f948ec2043ac4 (patch)
tree2647ea1730c7eec2c0fc9ff85efb31a09adda38c /xfce-base
parentVersion bump. (diff)
downloadgentoo-2-2c5c169af0b3fc3e226b8ea0f32f948ec2043ac4.tar.gz
gentoo-2-2c5c169af0b3fc3e226b8ea0f32f948ec2043ac4.tar.bz2
gentoo-2-2c5c169af0b3fc3e226b8ea0f32f948ec2043ac4.zip
Version bump.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/ChangeLog7
-rw-r--r--xfce-base/xfconf/xfconf-4.7.4.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index 43ea9d44ac10..1235aaf2a206 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.42 2010/09/06 12:37:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.43 2010/12/03 21:35:48 ssuominen Exp $
+
+*xfconf-4.7.4 (03 Dec 2010)
+
+ 03 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +xfconf-4.7.4.ebuild:
+ Version bump.
*xfconf-4.7.3 (06 Sep 2010)
diff --git a/xfce-base/xfconf/xfconf-4.7.4.ebuild b/xfce-base/xfconf/xfconf-4.7.4.ebuild
new file mode 100644
index 000000000000..99f7bceec44d
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.7.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.7.4.ebuild,v 1.1 2010/12/03 21:35:48 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce configuration daemon and utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/xfconf/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="debug perl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.18:2
+ >=xfce-base/libxfce4util-4.6
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_enable perl perl-bindings)
+ --disable-gtk-doc
+ --disable-gtk-doc-html
+ --disable-gtk-doc-pdf
+ $(use_enable debug)
+ $(use_enable debug checks)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}