summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-05 15:14:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-05 15:14:00 +0000
commit4e8167dd61dd78fbd5438e10a4be6773f9bae976 (patch)
treec8161657d4c71f77bed776849047f5fda0922138 /xfce-base
parentStable for HPPA (bug #459158). (diff)
downloadgentoo-2-4e8167dd61dd78fbd5438e10a4be6773f9bae976.tar.gz
gentoo-2-4e8167dd61dd78fbd5438e10a4be6773f9bae976.tar.bz2
gentoo-2-4e8167dd61dd78fbd5438e10a4be6773f9bae976.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/ChangeLog9
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.10.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index 09d5fb754b10..2fb98a5ac94c 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfdesktop
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.224 2012/11/28 12:30:40 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.225 2013/03/05 15:14:00 ssuominen Exp $
+
+*xfdesktop-4.10.1 (05 Mar 2013)
+
+ 05 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> +xfdesktop-4.10.1.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> xfdesktop-4.10.0.ebuild:
EAPI5
diff --git a/xfce-base/xfdesktop/xfdesktop-4.10.1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.10.1.ebuild
new file mode 100644
index 000000000000..246b0c17a92e
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.10.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.10.1.ebuild,v 1.1 2013/03/05 15:14:00 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify thunar"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.30:1
+ x11-libs/libX11
+ >=xfce-base/exo-0.8
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ thunar? (
+ >=xfce-base/thunar-1.6[dbus]
+ >=dev-libs/dbus-glib-0.100
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}