summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-10-21 09:28:20 +0000
committerSamuli Suominen <drac@gentoo.org>2007-10-21 09:28:20 +0000
commit62b9134fee5cc229f6c895c24a4cc57d801b650f (patch)
treea056233fc01230cf4188f75d895f213d32d23b8a /xfce-base
parentinitial ebuild (diff)
downloadgentoo-2-62b9134fee5cc229f6c895c24a4cc57d801b650f.tar.gz
gentoo-2-62b9134fee5cc229f6c895c24a4cc57d801b650f.tar.bz2
gentoo-2-62b9134fee5cc229f6c895c24a4cc57d801b650f.zip
Fix panel crashing with GTK+-2.12 when removing one. Thanks to Debian maintainer Corsac for letting us know.
(Portage version: 2.1.3.15)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/ChangeLog9
-rw-r--r--xfce-base/xfce4-panel/files/digest-xfce4-panel-4.4.1-r13
-rw-r--r--xfce-base/xfce4-panel/files/xfce4-panel-4.4.1-gtk212.patch13
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.4.1-r1.ebuild37
4 files changed, 61 insertions, 1 deletions
diff --git a/xfce-base/xfce4-panel/ChangeLog b/xfce-base/xfce4-panel/ChangeLog
index 0e6f28b1c76d..687632a5a869 100644
--- a/xfce-base/xfce4-panel/ChangeLog
+++ b/xfce-base/xfce4-panel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/xfce4-panel
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.104 2007/06/07 18:26:50 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.105 2007/10/21 09:28:19 drac Exp $
+
+*xfce4-panel-4.4.1-r1 (21 Oct 2007)
+
+ 21 Oct 2007; Samuli Suominen <drac@gentoo.org>
+ +files/xfce4-panel-4.4.1-gtk212.patch, +xfce4-panel-4.4.1-r1.ebuild:
+ Fix panel crashing with GTK+-2.12 when removing one. Thanks to Debian
+ maintainer Corsac for letting us know.
07 Jun 2007; Samuli Suominen <drac@gentoo.org> xfce4-panel-4.4.1.ebuild:
Stable on arm.
diff --git a/xfce-base/xfce4-panel/files/digest-xfce4-panel-4.4.1-r1 b/xfce-base/xfce4-panel/files/digest-xfce4-panel-4.4.1-r1
new file mode 100644
index 000000000000..f6b6af03f6d1
--- /dev/null
+++ b/xfce-base/xfce4-panel/files/digest-xfce4-panel-4.4.1-r1
@@ -0,0 +1,3 @@
+MD5 56b3137c190dd722dd5109be03901feb xfce4-panel-4.4.1.tar.bz2 767669
+RMD160 53d804b18b363e3571d065435163a6f74df6b3ed xfce4-panel-4.4.1.tar.bz2 767669
+SHA256 a84cfc376b1c15f941177d5189668694db365591a4132cbd4d1ac5c7da3f43fa xfce4-panel-4.4.1.tar.bz2 767669
diff --git a/xfce-base/xfce4-panel/files/xfce4-panel-4.4.1-gtk212.patch b/xfce-base/xfce4-panel/files/xfce4-panel-4.4.1-gtk212.patch
new file mode 100644
index 000000000000..dbc6c2db0101
--- /dev/null
+++ b/xfce-base/xfce4-panel/files/xfce4-panel-4.4.1-gtk212.patch
@@ -0,0 +1,13 @@
+Index: xfce4-panel/panel/panel-dialogs.c
+===================================================================
+--- xfce4-panel/panel/panel-dialogs.c (revision 26045)
++++ xfce4-panel/panel/panel-dialogs.c (revision 26046)
+@@ -1429,7 +1429,7 @@
+ {
+ int n = gtk_combo_box_get_active (combo);
+
+- if (n == pmd->current)
++ if (n == pmd->current || n < 0)
+ return;
+
+ pmd->current = n;
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.4.1-r1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.4.1-r1.ebuild
new file mode 100644
index 000000000000..8d940f845b7c
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.4.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.4.1-r1.ebuild,v 1.1 2007/10/21 09:28:19 drac Exp $
+
+inherit eutils xfce44
+
+XFCE_VERSION=4.4.1
+xfce44
+
+DESCRIPTION="Panel"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-panel/"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug doc startup-notification"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ gnome-base/librsvg
+ >=x11-libs/gtk+-2.6
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_MASTER_VERSION}
+ >=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ !<xfce-base/xfce-utils-4.4"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README README.Plugins"
+
+xfce44_core_package
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gtk212.patch
+}