summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-05 21:26:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-05 21:26:01 +0000
commit9a12b38b0fe29ca0c73131506948aa64ea7a78e3 (patch)
treea429cdc75f889c771dd9326b7cff1e7e0876b4e1 /xfce-base
parentVersion bump. (diff)
downloadgentoo-2-9a12b38b0fe29ca0c73131506948aa64ea7a78e3.tar.gz
gentoo-2-9a12b38b0fe29ca0c73131506948aa64ea7a78e3.tar.bz2
gentoo-2-9a12b38b0fe29ca0c73131506948aa64ea7a78e3.zip
Version bump.
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.5.4.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 324dba109f55..64315759c8bc 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.42 2010/08/29 17:55:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.43 2010/09/05 21:26:01 ssuominen Exp $
+
+*exo-0.5.4 (05 Sep 2010)
+
+ 05 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> +exo-0.5.4.ebuild:
+ Version bump.
29 Aug 2010; Raúl Porcel <armin76@gentoo.org> exo-0.3.107.ebuild:
alpha/ia64/sparc stable wrt #323729
diff --git a/xfce-base/exo/exo-0.5.4.ebuild b/xfce-base/exo/exo-0.5.4.ebuild
new file mode 100644
index 000000000000..bb9d9c8a5ee2
--- /dev/null
+++ b/xfce-base/exo/exo-0.5.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.5.4.ebuild,v 1.1 2010/09/05 21:26:01 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+
+inherit xfconf python
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo"
+SRC_URI="mirror://xfce/src/xfce/exo/0.5/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.2.2
+ python? ( >=dev-python/pygtk-2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ PATCHES=( "${FILESDIR}"/${PN}-0.5.3-opera-10_60.patch )
+ XFCONF="--docdir=${EPREFIX}/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable python)
+ $(xfconf_use_debug)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+
+ xfconf_src_prepare
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ python_mod_optimize exo-0.5 pyexo.py
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ python_mod_cleanup exo-0.5 pyexo.py
+}