summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-02-05 22:42:50 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-02-05 22:42:50 +0000
commitaad4dd982016a1180dade56b640450f07ad927f6 (patch)
tree647b8a21fa31cecc69c2f3534f2220c4601870dc /xfce-base
parentremove old/broken versions (diff)
downloadgentoo-2-aad4dd982016a1180dade56b640450f07ad927f6.tar.gz
gentoo-2-aad4dd982016a1180dade56b640450f07ad927f6.tar.bz2
gentoo-2-aad4dd982016a1180dade56b640450f07ad927f6.zip
EAPI 2 instead of built_with_use. xfce44.eclass is not EAPI 2 aware so going with a QA warning about econf in src_compile for now.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog8
-rw-r--r--xfce-base/thunar/thunar-0.9.3.ebuild21
2 files changed, 14 insertions, 15 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 99d7d5827f78..0ab52df8ad9b 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/thunar
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.65 2008/12/22 17:02:57 angelos Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.66 2009/02/05 22:42:50 betelgeuse Exp $
+
+ 05 Feb 2009; Petteri Räty <betelgeuse@gentoo.org> thunar-0.9.3.ebuild:
+ EAPI 2 instead of built_with_use. xfce44.eclass is not EAPI 2 aware so
+ going with a QA warning about econf in src_compile for now.
22 Dec 2008; Christoph Mende <angelos@gentoo.org> -thunar-0.9.0-r2.ebuild:
Removed old
diff --git a/xfce-base/thunar/thunar-0.9.3.ebuild b/xfce-base/thunar/thunar-0.9.3.ebuild
index 4ef21c064bac..b622848eb7a0 100644
--- a/xfce-base/thunar/thunar-0.9.3.ebuild
+++ b/xfce-base/thunar/thunar-0.9.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.9.3.ebuild,v 1.8 2008/12/15 04:56:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.9.3.ebuild,v 1.9 2009/02/05 22:42:50 betelgeuse Exp $
-EAPI=1
+EAPI=2
inherit eutils virtualx xfce44 flag-o-matic
@@ -21,7 +21,7 @@ RDEPEND=">=dev-lang/perl-5.6
x11-libs/libSM
>=x11-libs/gtk+-2.6
>=dev-libs/glib-2.6
- >=xfce-extra/exo-0.3.4
+ >=xfce-extra/exo-0.3.4[hal?]
>=x11-misc/shared-mime-info-0.20
>=dev-util/desktop-file-utils-0.14
>=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
@@ -60,21 +60,16 @@ pkg_setup() {
else
XFCE_CONFIG+=" --disable-tpa-plugin"
fi
-
- local fail="Re-emerge xfce-extra/exo with USE hal."
- if use hal && ! built_with_use xfce-extra/exo hal; then
- eerror "${fail}"
- die "${fail}"
- fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9.0-missing-audio-cds-for-volman.patch \
"${FILESDIR}"/${PN}-0.9.0-fix-defuncts.patch
}
+# xfce44 is not EAPI 2 aware yet
+src_configure() { :; }
+
src_compile() {
append-flags -Wno-error
xfce44_src_compile