summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-05-26 13:21:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-05-26 13:21:25 +0000
commite93b6406168508006695aefeeeca39a8d6090d08 (patch)
tree6abed96db100bb8b0958a6d150ebd95fd7c79334 /xfce-base
parentsci-chemistry/ccpn: Todays python patches (diff)
downloadgentoo-2-e93b6406168508006695aefeeeca39a8d6090d08.tar.gz
gentoo-2-e93b6406168508006695aefeeeca39a8d6090d08.tar.bz2
gentoo-2-e93b6406168508006695aefeeeca39a8d6090d08.zip
Apply upstream patch for bug 466144 to fix exo_str_looks_like_an_uri() function. Thanks to "nandhp" for reporting and Sasha Medvedev for pointing out the patch.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog12
-rw-r--r--xfce-base/exo/exo-0.10.2-r1.ebuild40
-rw-r--r--xfce-base/exo/files/exo-0.10.2-exo_str_looks_like_an_uri.patch52
3 files changed, 102 insertions, 2 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 363621f13178..d7b41a136814 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-base/exo
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.100 2013/05/05 17:04:20 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.101 2014/05/26 13:21:25 ssuominen Exp $
+
+*exo-0.10.2-r1 (26 May 2014)
+
+ 26 May 2014; Samuli Suominen <ssuominen@gentoo.org> +exo-0.10.2-r1.ebuild,
+ +files/exo-0.10.2-exo_str_looks_like_an_uri.patch:
+ Apply upstream patch for bug 466144 to fix exo_str_looks_like_an_uri()
+ function. Thanks to "nandhp" for reporting and Sasha Medvedev for pointing out
+ the patch.
05 May 2013; Samuli Suominen <ssuominen@gentoo.org> -exo-0.8.0.ebuild:
old
diff --git a/xfce-base/exo/exo-0.10.2-r1.ebuild b/xfce-base/exo/exo-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..586540451689
--- /dev/null
+++ b/xfce-base/exo/exo-0.10.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.10.2-r1.ebuild,v 1.1 2014/05/26 13:21:25 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-exo_str_looks_like_an_uri.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}
diff --git a/xfce-base/exo/files/exo-0.10.2-exo_str_looks_like_an_uri.patch b/xfce-base/exo/files/exo-0.10.2-exo_str_looks_like_an_uri.patch
new file mode 100644
index 000000000000..9c813745691c
--- /dev/null
+++ b/xfce-base/exo/files/exo-0.10.2-exo_str_looks_like_an_uri.patch
@@ -0,0 +1,52 @@
+http://bugs.gentoo.org/466144
+
+From 05848bb3cb10ea19ef8cba607bdabcd25560063c Mon Sep 17 00:00:00 2001
+From: Felipe Contreras <felipe.contreras@gmail.com>
+Date: Sat, 18 May 2013 22:50:01 -0500
+Subject: Fix exo_str_looks_like_an_uri() (bug #10098).
+
+Commit d11199b (Check if uris also contain a slash (bug #9244)) tried to
+fix a hang in thunar by properly recognizing that 'http:' is not an URI,
+however, while doing so, it broke proper URIs like 'magnet:foo'.
+
+As the RFC clearly states:
+
+ The following are two example URIs and their component parts:
+
+ foo://example.com:8042/over/there?name=ferret#nose
+ \_/ \______________/\_________/ \_________/ \__/
+ | | | | |
+ scheme authority path query fragment
+ | _____________________|__
+ / \ / \
+ urn:example:animal:ferret:nose
+
+But even with this succinct example exo_str_looks_like_an_uri() fails.
+
+There is an easy solution; fail only when component part is missing
+('urn:'), but succeed otherwise.
+
+This solution fixes 'magnet:foo', and doesn't break the current
+expectation from thunar that 'http:' should fail, having the best of
+both worlds.
+
+[1] http://www.ietf.org/rfc/rfc3986.txt
+
+Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
+
+diff --git a/exo/exo-string.c b/exo/exo-string.c
+index 33f86f9..056b36a 100644
+--- a/exo/exo-string.c
++++ b/exo/exo-string.c
+@@ -429,7 +429,7 @@ exo_str_looks_like_an_uri (const gchar *str)
+ for (++s; g_ascii_isalnum (*s) || *s == '+' || *s == '-' || *s == '.'; ++s);
+
+ /* <scheme> must be followed by ":" */
+- return (*s == ':' && *(s+1) == '/');
++ return (*s == ':' && *(s+1) != '\0');
+ }
+
+ return FALSE;
+--
+cgit v0.10.1
+