summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-24 18:14:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-24 18:14:10 +0000
commit7c1c9d0d233b67933e7492bebf239a926c3d3a53 (patch)
treecd24c6f475c86956bd9c39be983bcde9e11d7d81 /xfce-extra/xfce4-hdaps
parentstable ppc, bug 309873 (diff)
downloadgentoo-2-7c1c9d0d233b67933e7492bebf239a926c3d3a53.tar.gz
gentoo-2-7c1c9d0d233b67933e7492bebf239a926c3d3a53.tar.bz2
gentoo-2-7c1c9d0d233b67933e7492bebf239a926c3d3a53.zip
Initial commit wrt #311145 by Michael Orlitzky.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-hdaps')
-rw-r--r--xfce-extra/xfce4-hdaps/ChangeLog10
-rw-r--r--xfce-extra/xfce4-hdaps/metadata.xml5
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.5.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-hdaps/ChangeLog b/xfce-extra/xfce4-hdaps/ChangeLog
new file mode 100644
index 000000000000..45d1cf374a28
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for xfce-extra/xfce4-hdaps
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.1 2010/03/24 18:14:10 ssuominen Exp $
+
+*xfce4-hdaps-0.0.5 (24 Mar 2010)
+
+ 24 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-hdaps-0.0.5.ebuild:
+ Initial commit wrt #311145 by Michael Orlitzky.
+
diff --git a/xfce-extra/xfce4-hdaps/metadata.xml b/xfce-extra/xfce4-hdaps/metadata.xml
new file mode 100644
index 000000000000..d56729e92f8e
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.5.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.5.ebuild
new file mode 100644
index 000000000000..19cd0c63304d
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.5.ebuild,v 1.1 2010/03/24 18:14:10 ssuominen Exp $
+
+EAPI=2
+inherit linux-info xfconf
+
+DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=xfce-base/libxfcegui4-4.3.99.2
+ >=xfce-base/libxfce4util-4.3.99.2
+ >=xfce-base/xfce4-panel-4.3.99.2"
+RDEPEND="${COMMON_DEPEND}
+ >=app-laptop/hdapsd-20081213
+ >=app-laptop/tp_smapi-0.39"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ XFCONF="--disable-option-checking
+ $(use_enable debug)"
+
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 28; then
+ ewarn
+ ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
+ ewarn
+ fi
+}