summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-10 07:45:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-10 07:45:02 +0000
commite5d71bda70611e83b5fb0b916b4bba0d10be9562 (patch)
treee7517f6f46880ef4a52189fc0708249908169278 /xfce-extra/xfce4-places-plugin
parenttidy (diff)
downloadgentoo-2-e5d71bda70611e83b5fb0b916b4bba0d10be9562.tar.gz
gentoo-2-e5d71bda70611e83b5fb0b916b4bba0d10be9562.tar.bz2
gentoo-2-e5d71bda70611e83b5fb0b916b4bba0d10be9562.zip
Port xfce4-places-plugin to exo-0.5 API wrt upstream #5754.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-places-plugin')
-rw-r--r--xfce-extra/xfce4-places-plugin/ChangeLog7
-rw-r--r--xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-exo.patch39
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild8
3 files changed, 51 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-places-plugin/ChangeLog b/xfce-extra/xfce4-places-plugin/ChangeLog
index 37abae65994c..20246cc0ae79 100644
--- a/xfce-extra/xfce4-places-plugin/ChangeLog
+++ b/xfce-extra/xfce4-places-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-places-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/ChangeLog,v 1.11 2010/03/26 09:33:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/ChangeLog,v 1.12 2010/09/10 07:45:02 ssuominen Exp $
+
+ 10 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-places-plugin-1.2.0.ebuild,
+ +files/xfce4-places-plugin-1.2.0-exo.patch:
+ Port xfce4-places-plugin to exo-0.5 API wrt upstream #5754.
26 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
xfce4-places-plugin-1.2.0.ebuild:
diff --git a/xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-exo.patch b/xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-exo.patch
new file mode 100644
index 000000000000..a137688a7bd4
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-exo.patch
@@ -0,0 +1,39 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=5754
+
+--- configure.in
++++ configure.in
+@@ -25,7 +25,7 @@
+ XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90.2])
+ XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.90.2])
+ XDT_CHECK_PACKAGE([THUNAR_VFS], [thunar-vfs-1], [0.3.2])
+-XDT_CHECK_PACKAGE([EXO], [exo-0.3], [0.3.1.1])
++XDT_CHECK_PACKAGE([EXO], [exo-1], [0.5])
+
+ dnl check for optional packages/versions
+ XDT_CHECK_OPTIONAL_PACKAGE([LIBXFCE4PANEL_46], [libxfce4panel-1.0], [4.5.92], [libxfce4panel46], [Take advantage of Xfce 4.6 panel changes])
+--- panel-plugin/support.c
++++ panel-plugin/support.c
+@@ -52,10 +52,9 @@
+
+ if(path != NULL && *path != '\0'){
+
+- DBG("exo_url_show(%s)", path);
+- exo_success = exo_url_show(path, NULL, NULL);
++ GError *error = NULL;
+
+- if(!exo_success){
++ if ( !gtk_show_uri (NULL, path, 0, &error)){
+ gchar *cmd = g_strconcat("thunar \"", path, "\"", NULL);
+ DBG("exec: %s", cmd);
+ places_gui_exec(cmd);
+@@ -114,8 +113,9 @@
+ void
+ places_load_file(const gchar *path)
+ {
++ GError *error = NULL;
+ if(path != NULL && *path != '\0')
+- exo_url_show(path, NULL, NULL);
++ gtk_show_uri (NULL , path, 0, &error);
+ }
+
+ /**
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild
index 5f65adfaf98e..bd32be90862e 100644
--- a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild,v 1.12 2010/09/10 07:39:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild,v 1.13 2010/09/10 07:45:02 ssuominen Exp $
EAPI=2
+EAUTORECONF=yes
inherit xfconf
DESCRIPTION="Places menu plug-in for panel, like GNOME's"
@@ -19,13 +20,16 @@ RDEPEND=">=x11-libs/gtk+-2.6:2
>=xfce-base/libxfcegui4-4.3.90.2
|| ( xfce-extra/thunar-vfs <xfce-base/thunar-1.1.0 )
>=xfce-base/exo-0.3.1.1
- <xfce-base/exo-0.5
>=xfce-base/xfce4-panel-4.5.92"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
pkg_setup() {
+ if has_version ">=xfce-base/exo-0.5"; then
+ PATCHES=( "${FILESDIR}"/${P}-exo.patch )
+ fi
+
XFCONF="--disable-dependency-tracking
$(xfconf_use_debug)"
DOCS="AUTHORS ChangeLog NEWS README TODO"