summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-05-31 11:24:05 +0000
committerChristoph Mende <angelos@gentoo.org>2011-05-31 11:24:05 +0000
commit5d88769eaee749953cde8f3dc1e3bb11404894b0 (patch)
tree8ff8934034a1c57c194d0cb4b2bd1320fec7fc73 /xfce-extra
parentFix underlinking (bug #369457) (diff)
downloadgentoo-2-5d88769eaee749953cde8f3dc1e3bb11404894b0.tar.gz
gentoo-2-5d88769eaee749953cde8f3dc1e3bb11404894b0.tar.bz2
gentoo-2-5d88769eaee749953cde8f3dc1e3bb11404894b0.zip
Fix underlinking (bug #367881)
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-places-plugin/ChangeLog9
-rw-r--r--xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-link-against-libx11.patch24
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild7
3 files changed, 36 insertions, 4 deletions
diff --git a/xfce-extra/xfce4-places-plugin/ChangeLog b/xfce-extra/xfce4-places-plugin/ChangeLog
index 20246cc0ae79..f06bf6792e3b 100644
--- a/xfce-extra/xfce4-places-plugin/ChangeLog
+++ b/xfce-extra/xfce4-places-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-places-plugin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/ChangeLog,v 1.12 2010/09/10 07:45:02 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/ChangeLog,v 1.13 2011/05/31 11:24:05 angelos Exp $
+
+ 31 May 2011; Christoph Mende <angelos@gentoo.org>
+ xfce4-places-plugin-1.2.0.ebuild,
+ +files/xfce4-places-plugin-1.2.0-link-against-libx11.patch:
+ Fix underlinking (bug #367881)
10 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
xfce4-places-plugin-1.2.0.ebuild,
diff --git a/xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-link-against-libx11.patch b/xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-link-against-libx11.patch
new file mode 100644
index 000000000000..e06a155aeb8c
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/files/xfce4-places-plugin-1.2.0-link-against-libx11.patch
@@ -0,0 +1,24 @@
+diff --git a/configure.in b/configure.in
+index 27f6da0..9c753fe 100644
+--- a/configure.in
++++ b/configure.in
+@@ -26,6 +26,7 @@ XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.3.90.2])
+ XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.3.90.2])
+ XDT_CHECK_PACKAGE([THUNAR_VFS], [thunar-vfs-1], [0.3.2])
+ XDT_CHECK_PACKAGE([EXO], [exo-1], [0.5])
++XDT_CHECK_LIBX11()
+
+ dnl check for optional packages/versions
+ XDT_CHECK_OPTIONAL_PACKAGE([LIBXFCE4PANEL_46], [libxfce4panel-1.0], [4.5.92], [libxfce4panel46], [Take advantage of Xfce 4.6 panel changes])
+diff --git a/panel-plugin/Makefile.am b/panel-plugin/Makefile.am
+index dcbcdf5..63e2027 100644
+--- a/panel-plugin/Makefile.am
++++ b/panel-plugin/Makefile.am
+@@ -59,6 +59,7 @@ xfce4_places_plugin_LDADD = \
+ $(LIBXFCE4UTIL_LIBS) \
+ $(LIBXFCEGUI4_LIBS) \
+ $(LIBXFCE4PANEL_LIBS) \
++ $(LIBX11_LIBS) \
+ @THUNAR_VFS_LIBS@
+
+
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild
index 3181078e2d38..7d0bbcf168b0 100644
--- a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild,v 1.16 2011/05/19 21:34:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.2.0.ebuild,v 1.17 2011/05/31 11:24:05 angelos Exp $
EAPI=4
EAUTORECONF=yes
@@ -26,7 +26,10 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- PATCHES=( "${FILESDIR}"/${P}-exo.patch )
+ PATCHES=(
+ "${FILESDIR}"/${P}-exo.patch
+ "${FILESDIR}"/${P}-link-against-libx11.patch
+ )
XFCONF=( $(xfconf_use_debug) )
DOCS=( AUTHORS ChangeLog NEWS README TODO )
}