summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-05-19 16:48:22 +0000
committerJason Zaman <perfinion@gentoo.org>2015-05-19 16:48:22 +0000
commita8bd7a2e5d57936535e7e211b11f2f45431e6ce4 (patch)
tree5a4505fafbd5c2fd0b2cd893a000444e768f1f99 /xfce-extra
parentOld. (diff)
downloadgentoo-2-a8bd7a2e5d57936535e7e211b11f2f45431e6ce4.tar.gz
gentoo-2-a8bd7a2e5d57936535e7e211b11f2f45431e6ce4.tar.bz2
gentoo-2-a8bd7a2e5d57936535e7e211b11f2f45431e6ce4.zip
fix fileroller and engrampa. PR https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/104 thanks to brakarov
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-archive-plugin/ChangeLog12
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch68
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch15
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild31
4 files changed, 124 insertions, 2 deletions
diff --git a/xfce-extra/thunar-archive-plugin/ChangeLog b/xfce-extra/thunar-archive-plugin/ChangeLog
index 1fa451282433..f5ec94b1514a 100644
--- a/xfce-extra/thunar-archive-plugin/ChangeLog
+++ b/xfce-extra/thunar-archive-plugin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-extra/thunar-archive-plugin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/ChangeLog,v 1.30 2014/04/22 13:57:25 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/ChangeLog,v 1.31 2015/05/19 16:48:22 perfinion Exp $
+
+*thunar-archive-plugin-0.3.1-r1 (19 May 2015)
+
+ 19 May 2015; Jason Zaman <perfinion@gentoo.org>
+ +files/0.3.1-add-engrampa-support.patch, +files/0.3.1-fix-file-roller.patch,
+ +thunar-archive-plugin-0.3.1-r1.ebuild:
+ fix fileroller and engrampa. PR https://github.com/gentoo/gentoo-portage-
+ rsync-mirror/pull/104 thanks to brakarov
22 Apr 2014; Samuli Suominen <ssuominen@gentoo.org>
-thunar-archive-plugin-0.3.0.ebuild:
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch
new file mode 100644
index 000000000000..becccda1ac59
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch
@@ -0,0 +1,68 @@
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 4da529c..ec49cba 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -3,7 +3,8 @@
+ wrapperdir = $(libexecdir)/thunar-archive-plugin
+ wrapper_SCRIPTS = \
+ ark.tap \
+- file-roller.tap
++ file-roller.tap \
++ engrampa.tap
+
+ # Install symlink to 'gnome-file-roller.tap'
+ install-exec-hook:
+diff --git a/scripts/engrampa.tap b/scripts/engrampa.tap
+index e69de29..a9d9c10 100755
+--- a/scripts/engrampa.tap
++++ b/scripts/engrampa.tap
+@@ -0,0 +1,48 @@
++#!/bin/sh
++#
++# engrampa.tap - Wrapper script to create and extract archive files
++# in Thunar, via the thunar-archive-plugin, using the
++# engrampa archive manager.
++#
++# $Id: 0.3.1-add-engrampa-support.patch,v 1.1 2015/05/19 16:48:22 perfinion Exp $
++#
++# Copyright (c) 2006 Benedikt Meurer <benny@xfce.org>.
++#
++# This program is free software; you can redistribute it and/or modify it
++# under the terms of the GNU General Public License as published by the Free
++# Software Foundation; either version 2 of the License, or (at your option)
++# any later version.
++#
++# This program is distributed in the hope that it will be useful, but WITHOUT
++# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
++# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
++# more details.
++#
++# You should have received a copy of the GNU General Public License along with
++# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
++# Place, Suite 330, Boston, MA 02111-1307 USA.
++#
++
++# determine the action and the folder, $@ then contains only the files
++action=$1; shift;
++folder=$1; shift;
++
++# check the action
++case $action in
++create)
++ exec engrampa "--default-dir=$folder" --add "$@"
++ ;;
++
++extract-here)
++ exec engrampa "--extract-to=$folder" --force "$@"
++ ;;
++
++extract-to)
++ exec engrampa --extract "$@"
++ ;;
++
++*)
++ echo "Unsupported action '$action'" >&2
++ exit 1
++esac
++
+
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch
new file mode 100644
index 000000000000..094480212f12
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch
@@ -0,0 +1,15 @@
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 4da529c..2ba8dec 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -9,8 +9,8 @@ wrapper_SCRIPTS = \
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(wrapperdir)
+ -( cd $(DESTDIR)$(wrapperdir) ; \
+- test -f gnome-file-roller.tap \
+- || ln -sf file-roller.tap gnome-file-roller.tap )
++ ln -sf file-roller.tap gnome-file-roller.tap; \
++ ln -sf file-roller.tap org.gnome.FileRoller.tap; )
+
+ EXTRA_DIST = \
+ $(wrapper_SCRIPTS) \
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..16685f6d1619
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild,v 1.1 2015/05/19 16:48:22 perfinion Exp $
+
+EAPI=5
+
+EAUTORECONF="yes"
+inherit xfconf
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/thunar-1.2:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/0.3.1-add-engrampa-support.patch "${FILESDIR}"/0.3.1-fix-file-roller.patch )
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}