summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/qrupdate/ChangeLog9
-rw-r--r--sci-libs/qrupdate/qrupdate-1.0.1.ebuild4
-rw-r--r--sci-libs/qrupdate/qrupdate-1.1.0.ebuild48
3 files changed, 57 insertions, 4 deletions
diff --git a/sci-libs/qrupdate/ChangeLog b/sci-libs/qrupdate/ChangeLog
index 7732448a0652..2e5094c06f33 100644
--- a/sci-libs/qrupdate/ChangeLog
+++ b/sci-libs/qrupdate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/qrupdate
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.6 2009/12/26 15:43:45 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/ChangeLog,v 1.7 2010/01/12 05:16:13 markusle Exp $
+
+*qrupdate-1.1.0 (12 Jan 2010)
+
+ 12 Jan 2010; Markus Dittrich <markusle@gentoo.org> +qrupdate-1.1.0.ebuild:
+ Version bump.
26 Dec 2009; Raúl Porcel <armin76@gentoo.org> qrupdate-1.0.1.ebuild:
Add ~sparc wrt #285149
diff --git a/sci-libs/qrupdate/qrupdate-1.0.1.ebuild b/sci-libs/qrupdate/qrupdate-1.0.1.ebuild
index fcb88d64cb73..16433c40f14f 100644
--- a/sci-libs/qrupdate/qrupdate-1.0.1.ebuild
+++ b/sci-libs/qrupdate/qrupdate-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.0.1.ebuild,v 1.6 2009/12/26 15:43:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.0.1.ebuild,v 1.7 2010/01/12 05:16:13 markusle Exp $
EAPI="2"
diff --git a/sci-libs/qrupdate/qrupdate-1.1.0.ebuild b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
new file mode 100644
index 000000000000..e6c1b69f303b
--- /dev/null
+++ b/sci-libs/qrupdate/qrupdate-1.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qrupdate/qrupdate-1.1.0.ebuild,v 1.1 2010/01/12 05:16:13 markusle Exp $
+
+EAPI="2"
+
+inherit eutils fortran
+
+DESCRIPTION="A library for fast updating of QR and Cholesky decompositions"
+HOMEPAGE="http://sourceforge.net/projects/qrupdate"
+SRC_URI="mirror://sourceforge/qrupdate/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran ifc g77"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.1-makefile.patch
+
+ local BLAS_LIBS="$(pkg-config --libs blas)"
+ local LAPACK_LIBS="$(pkg-config --libs lapack)"
+
+ sed -i Makeconf \
+ -e "s:gfortran:${FORTRANC}:g" \
+ -e "s:FFLAGS=.*:FFLAGS=${FFLAGS}:" \
+ -e "s:BLAS=.*:BLAS=${BLAS_LIBS}:" \
+ -e "s:LAPACK=.*:LAPACK=${LAPACK_LIBS}:" \
+ || die "Failed to set up Makeconf"
+}
+
+src_compile() {
+ emake solib || die "emake failed"
+}
+
+src_install() {
+ dolib.so libqrupdate.so \
+ || die "Failed to install libqrupdate.so"
+
+ dodoc README ChangeLog || die "dodoc failed"
+}