summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/git/ChangeLog7
-rw-r--r--dev-vcs/git/git-2.0.2.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild9
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild9
-rw-r--r--dev-vcs/git/git-9999.ebuild9
6 files changed, 41 insertions, 11 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index a6fc39254a8d..7c92bc3edaef 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.270 2014/07/20 21:22:53 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.271 2014/07/27 10:38:48 grobian Exp $
+
+ 27 Jul 2014; Fabian Groffen <grobian@gentoo.org> git-2.0.2.ebuild,
+ git-9999.ebuild, git-9999-r1.ebuild, git-9999-r2.ebuild, git-9999-r3.ebuild:
+ Fix compilation with USE=subversion on platforms without intl and iconv in
+ libc, bug #516168
*git-2.0.2 (20 Jul 2014)
diff --git a/dev-vcs/git/git-2.0.2.ebuild b/dev-vcs/git/git-2.0.2.ebuild
index 33b4b989a225..dab940ba4867 100644
--- a/dev-vcs/git/git-2.0.2.ebuild
+++ b/dev-vcs/git/git-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-2.0.2.ebuild,v 1.1 2014/07/20 21:22:53 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-2.0.2.ebuild,v 1.2 2014/07/27 10:38:48 grobian Exp $
EAPI=5
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index e9b68030975a..9b57293c0dd1 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.3 2014/06/24 01:44:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r1.ebuild,v 1.4 2014/07/27 10:38:48 grobian Exp $
EAPI=5
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 49f3bcee7143..e755b27660f9 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v 1.3 2014/06/24 01:44:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r2.ebuild,v 1.4 2014/07/27 10:38:48 grobian Exp $
EAPI=5
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index de502e90cec2..f3ec8c10fe8d 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v 1.4 2014/06/24 01:44:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999-r3.ebuild,v 1.5 2014/07/27 10:38:48 grobian Exp $
EAPI=5
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 092cc354b435..119fc90b1eea 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.58 2014/06/24 01:44:07 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.59 2014/07/27 10:38:48 grobian Exp $
EAPI=5
@@ -325,7 +325,12 @@ src_compile() {
if use subversion ; then
cd "${S}"/contrib/svn-fe
- git_emake EXTLIBS="${EXTLIBS}" || die "emake svn-fe failed"
+ # by defining EXTLIBS we override the detection for libintl and
+ # libiconv, bug #516168
+ local nlsiconv=
+ use nls && use !elibc_glibc && nlsiconv+=" -lintl"
+ use iconv && use !elibc_glibc && nlsiconv+=" -liconv"
+ git_emake EXTLIBS="${EXTLIBS} ${nlsiconv}" || die "emake svn-fe failed"
if use doc ; then
git_emake svn-fe.{1,html} || die "emake svn-fe.1 svn-fe.html failed"
fi