summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/lightspark/ChangeLog8
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.2-ndebug.patch138
-rw-r--r--www-plugins/lightspark/lightspark-0.4.2_rc2.ebuild62
3 files changed, 207 insertions, 1 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 13538217d03d..b141918b4100 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.6 2010/06/07 13:17:29 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.7 2010/07/05 22:41:07 chithanh Exp $
+
+*lightspark-0.4.2_rc2 (05 Jul 2010)
+
+ 05 Jul 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +lightspark-0.4.2_rc2.ebuild, +files/lightspark-0.4.2-ndebug.patch:
+ Add release candidate.
*lightspark-0.4.1 (07 Jun 2010)
diff --git a/www-plugins/lightspark/files/lightspark-0.4.2-ndebug.patch b/www-plugins/lightspark/files/lightspark-0.4.2-ndebug.patch
new file mode 100644
index 000000000000..f0c593540f70
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.2-ndebug.patch
@@ -0,0 +1,138 @@
+=== modified file 'CMakeLists.txt'
+--- CMakeLists.txt 2010-07-01 01:24:10 +0000
++++ CMakeLists.txt 2010-07-04 16:57:13 +0000
+@@ -123,9 +123,9 @@
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wnon-virtual-dtor -Woverloaded-virtual -pipe -fvisibility=hidden")
+ SET(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -DEXPENSIVE_DEBUG")
+ SET(CMAKE_CXX_FLAGS_PROFILE "-g -pg -O2")
+-SET(CMAKE_CXX_FLAGS_RELEASE "-O3")
+-SET(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-g -O2")
+-SET(CMAKE_CXX_FLAGS_DEBIAN "-O2")
++SET(CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG")
++SET(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-g -O2 -DNDEBUG")
++SET(CMAKE_CXX_FLAGS_DEBIAN "-O2 -DNDEBUG")
+
+ ADD_DEFINITIONS(-DDATADIR="${CMAKE_INSTALL_PREFIX}/share/lightspark")
+
+
+=== modified file 'abc_opcodes.cpp'
+--- abc_opcodes.cpp 2010-06-20 15:00:39 +0000
++++ abc_opcodes.cpp 2010-07-04 16:57:13 +0000
+@@ -644,11 +644,15 @@
+ ret=Class<ASObject>::getInstanceS();
+ if(sf->mi->body)
+ {
++#ifndef NDEBUG
+ ret->initialized=false;
++#endif
+ LOG(LOG_CALLS,"Building method traits");
+ for(unsigned int i=0;i<sf->mi->body->trait_count;i++)
+ th->context->buildTrait(ret,&sf->mi->body->traits[i],false);
++#ifndef NDEBUG
+ ret->initialized=true;
++#endif
+ ret->incRef();
+ assert_and_throw(sf->closure_this==NULL);
+ ASObject* ret2=sf->call(ret,args,m,0);
+@@ -1913,11 +1917,15 @@
+ ret=Class<ASObject>::getInstanceS();
+ if(sf->mi->body)
+ {
++#ifndef NDEBUG
+ ret->initialized=false;
++#endif
+ LOG(LOG_CALLS,"Building method traits");
+ for(unsigned int i=0;i<sf->mi->body->trait_count;i++)
+ th->context->buildTrait(ret,&sf->mi->body->traits[i],false);
++#ifndef NDEBUG
+ ret->initialized=true;
++#endif
+ ret->incRef();
+ assert_and_throw(sf->closure_this==NULL);
+ ASObject* ret2=sf->call(ret,args,m,0);
+@@ -2181,10 +2189,14 @@
+ //TODO: Should create a real activation object
+ //TODO: Should method traits be added to the activation context?
+ ASObject* act=Class<ASObject>::getInstanceS();
++#ifndef NDEBUG
+ act->initialized=false;
++#endif
+ for(unsigned int i=0;i<info->body->trait_count;i++)
+ th->context->buildTrait(act,&info->body->traits[i],false);
++#ifndef NDEBUG
+ act->initialized=true;
++#endif
+
+ return act;
+ }
+
+=== modified file 'asobjects.cpp'
+--- asobjects.cpp 2010-06-30 01:41:37 +0000
++++ asobjects.cpp 2010-07-04 16:57:13 +0000
+@@ -1727,7 +1727,9 @@
+ }*/
+ if(buildAndLink)
+ {
++ #ifndef NDEBUG
+ assert_and_throw(!target->initialized);
++ #endif
+ //HACK: suppress implementation handling of variables just now
+ bool bak=target->implEnable;
+ target->implEnable=false;
+
+=== modified file 'swf.cpp'
+--- swf.cpp 2010-07-03 21:26:00 +0000
++++ swf.cpp 2010-07-04 16:57:13 +0000
+@@ -653,7 +653,7 @@
+ break;
+ case ButtonPress:
+ {
+- cout << "Press" << endl;
++ //cout << "Press" << endl;
+ Locker locker(th->mutexListeners);
+ th->m_sys->renderThread->requestInput();
+ float selected=th->m_sys->renderThread->getIdAt(xevent->xbutton.x,xevent->xbutton.y);
+@@ -674,7 +674,7 @@
+ }
+ case ButtonRelease:
+ {
+- cout << "Release" << endl;
++ //cout << "Release" << endl;
+ Locker locker(th->mutexListeners);
+ sys->renderThread->requestInput();
+ float selected=sys->renderThread->getIdAt(xevent->xbutton.x,xevent->xbutton.y);
+
+=== modified file 'swftypes.cpp'
+--- swftypes.cpp 2010-06-30 01:23:30 +0000
++++ swftypes.cpp 2010-07-04 16:57:13 +0000
+@@ -263,7 +263,9 @@
+ void ASObject::setGetterByQName(const tiny_string& name, const tiny_string& ns, IFunction* o)
+ {
+ check();
++#ifndef NDEBUG
+ assert_and_throw(!initialized);
++#endif
+ //Getters are inserted with the current level of the prototype chain
+ int level=cur_level;
+ obj_var* obj=Variables.findObjVar(name,ns,level,true,false);
+@@ -279,7 +281,9 @@
+ void ASObject::setSetterByQName(const tiny_string& name, const tiny_string& ns, IFunction* o)
+ {
+ check();
++#ifndef NDEBUG
+ assert_and_throw(!initialized);
++#endif
+ //Setters are inserted with the current level of the prototype chain
+ int level=cur_level;
+ obj_var* obj=Variables.findObjVar(name,ns,level,true,false);
+@@ -579,7 +583,9 @@
+ void ASObject::initSlot(unsigned int n,const tiny_string& name, const tiny_string& ns)
+ {
+ //Should be correct to use the level on the prototype chain
++#ifndef NDEBUG
+ assert_and_throw(!initialized);
++#endif
+ Variables.initSlot(n,cur_level,name,ns);
+ }
+
+
diff --git a/www-plugins/lightspark/lightspark-0.4.2_rc2.ebuild b/www-plugins/lightspark/lightspark-0.4.2_rc2.ebuild
new file mode 100644
index 000000000000..dbc5dfd5bada
--- /dev/null
+++ b/www-plugins/lightspark/lightspark-0.4.2_rc2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.2_rc2.ebuild,v 1.1 2010/07/05 22:41:07 chithanh Exp $
+
+EAPI=3
+inherit cmake-utils nsplugins multilib
+
+DESCRIPTION="High performance flash player"
+HOMEPAGE="https://launchpad.net/lightspark/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PN}-0.4.0/+download/${P/_/}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nsplugin pulseaudio"
+
+RDEPEND="dev-libs/libpcre
+ media-fonts/liberation-fonts
+ media-video/ffmpeg
+ media-libs/ftgl
+ >=media-libs/glew-1.5.3
+ media-libs/libsdl
+ net-misc/curl
+ >=sys-devel/llvm-2.7
+ virtual/opengl
+ nsplugin? (
+ dev-libs/nspr
+ net-libs/xulrunner
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ )
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${P/_rc*/}
+
+src_prepare() {
+ # Fix gcc complaint about undefined debug variable
+ epatch "${FILESDIR}"/${PN}-0.4.2-ndebug.patch
+
+ # Adjust plugin permissions
+ sed -i "s|FILES|PROGRAMS|" plugin-dir/CMakeLists.txt || die
+
+ # Adjust font paths
+ sed -i "s|truetype/ttf-liberation|liberation-fonts|" swf.cpp || die
+}
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use nsplugin COMPILE_PLUGIN)
+ $(cmake-utils_use pulseaudio ENABLE_SOUND)
+ -DPLUGIN_DIRECTORY=/usr/$(get_libdir)/${PN}/plugins"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use nsplugin && inst_plugin /usr/$(get_libdir)/${PN}/plugins/liblightsparkplugin.so
+}