summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/libgnomecanvasmm/ChangeLog8
-rw-r--r--dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.23.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-cpp/libgnomecanvasmm/ChangeLog b/dev-cpp/libgnomecanvasmm/ChangeLog
index ae24f0c89088..88e387e686c3 100644
--- a/dev-cpp/libgnomecanvasmm/ChangeLog
+++ b/dev-cpp/libgnomecanvasmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libgnomecanvasmm
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/ChangeLog,v 1.67 2008/09/30 17:28:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/ChangeLog,v 1.68 2008/11/17 22:49:20 eva Exp $
+
+*libgnomecanvasmm-2.23.1 (17 Nov 2008)
+
+ 17 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +libgnomecanvasmm-2.23.1.ebuild:
+ New version for GNOME 2.24. Add a new constructor (CanvasAA).
30 Sep 2008; Jeroen Roovers <jer@gentoo.org>
libgnomecanvasmm-2.22.0.ebuild:
diff --git a/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.23.1.ebuild b/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.23.1.ebuild
new file mode 100644
index 000000000000..b7474efab23d
--- /dev/null
+++ b/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.23.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.23.1.ebuild,v 1.1 2008/11/17 22:49:20 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for libgnomecanvas"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=gnome-base/libgnomecanvas-2.6
+ >=dev-cpp/gtkmm-2.4"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO INSTALL"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use doc; then
+ cd "${S}/docs/reference"
+ make all || die "failed to build API docs"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+
+ if use examples; then
+ cp -R examples "${D}/usr/share/doc/${PF}"
+ fi
+}