summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/hrktorrent/ChangeLog7
-rw-r--r--net-p2p/hrktorrent/files/digest-hrktorrent-0.2.33
-rw-r--r--net-p2p/hrktorrent/hrktorrent-0.2.3.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/net-p2p/hrktorrent/ChangeLog b/net-p2p/hrktorrent/ChangeLog
index 2d93c0797949..fe7464d0347c 100644
--- a/net-p2p/hrktorrent/ChangeLog
+++ b/net-p2p/hrktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/hrktorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.3 2007/11/26 19:32:46 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/ChangeLog,v 1.4 2007/12/02 15:41:33 drac Exp $
+
+*hrktorrent-0.2.3 (02 Dec 2007)
+
+ 02 Dec 2007; Samuli Suominen <drac@gentoo.org> +hrktorrent-0.2.3.ebuild:
+ Version bump, drop patch since it was applied upstream.
26 Nov 2007; Samuli Suominen <drac@gentoo.org>
+files/hrktorrent-0.2.2-Makefile.patch, hrktorrent-0.2.2.ebuild:
diff --git a/net-p2p/hrktorrent/files/digest-hrktorrent-0.2.3 b/net-p2p/hrktorrent/files/digest-hrktorrent-0.2.3
new file mode 100644
index 000000000000..546ffcff46d4
--- /dev/null
+++ b/net-p2p/hrktorrent/files/digest-hrktorrent-0.2.3
@@ -0,0 +1,3 @@
+MD5 3df226a7e3d838c39157106618d9a7ff hrktorrent-0.2.3.tar.bz2 5867
+RMD160 64f59d2cd63f88d271f108141a6a2a7d2b6d96a6 hrktorrent-0.2.3.tar.bz2 5867
+SHA256 ffddfc748d751c71181b82add1ddfcaaa7269edd74219164796267df8432b049 hrktorrent-0.2.3.tar.bz2 5867
diff --git a/net-p2p/hrktorrent/hrktorrent-0.2.3.ebuild b/net-p2p/hrktorrent/hrktorrent-0.2.3.ebuild
new file mode 100644
index 000000000000..99bc7dc79b3b
--- /dev/null
+++ b/net-p2p/hrktorrent/hrktorrent-0.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hrktorrent/hrktorrent-0.2.3.ebuild,v 1.1 2007/12/02 15:41:33 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A slim rb_libtorrent based console torrent application supporting DHT"
+HOMEPAGE="http://henrik.unit5.ca/hrktorrent"
+SRC_URI="http://henrik.unit5.ca/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=net-libs/rb_libtorrent-0.12*"
+DEPEND="${RDEPEND}
+ dev-cpp/asio
+ dev-util/pkgconfig"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc CHANGELOG README ${PN}.rc.example
+}
+
+pkg_postinst() {
+ local docsuffix=$(ecompress --suffix)
+
+ elog "A sample configuration file for ${PN} can be found in"
+ elog "/usr/share/doc/${PF}/hrktorrent.rc.example${docsuffix}"
+ elog "To use a config file, extract it, put it in your home directory"
+ elog "and name it \".hrktorrent.rc\""
+}