summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lisp/cl-png/ChangeLog6
-rw-r--r--dev-lisp/cl-png/cl-png-0.2.1-r1.ebuild25
-rw-r--r--dev-lisp/cl-png/cl-png-0.2.1.ebuild33
-rw-r--r--dev-lisp/cl-png/cl-png-0.2.ebuild27
-rw-r--r--dev-lisp/cl-png/cl-png-0.4.ebuild4
-rw-r--r--dev-lisp/cl-png/files/digest-cl-png-0.21
-rw-r--r--dev-lisp/cl-png/files/digest-cl-png-0.2.11
-rw-r--r--dev-lisp/cl-png/files/digest-cl-png-0.2.1-r11
8 files changed, 7 insertions, 91 deletions
diff --git a/dev-lisp/cl-png/ChangeLog b/dev-lisp/cl-png/ChangeLog
index b545bc5ca6bc..bd022044505a 100644
--- a/dev-lisp/cl-png/ChangeLog
+++ b/dev-lisp/cl-png/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-png
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/ChangeLog,v 1.7 2005/04/11 07:59:41 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/ChangeLog,v 1.8 2005/04/16 23:18:00 mkennedy Exp $
+
+ 16 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org> -cl-png-0.2.ebuild,
+ -cl-png-0.2.1.ebuild, -cl-png-0.2.1-r1.ebuild, cl-png-0.4.ebuild:
+ Keywording
11 Apr 2005; Matthew Kennedy <mkennedy@gentoo.org> cl-png-0.4.ebuild:
Keywording for ~amd64
diff --git a/dev-lisp/cl-png/cl-png-0.2.1-r1.ebuild b/dev-lisp/cl-png/cl-png-0.2.1-r1.ebuild
deleted file mode 100644
index 85eb528776ce..000000000000
--- a/dev-lisp/cl-png/cl-png-0.2.1-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.2.1-r1.ebuild,v 1.3 2004/07/14 15:59:17 agriffis Exp $
-
-inherit common-lisp
-
-DESCRIPTION="Common Lisp package to read and write PNG image files"
-HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
- http://www.cliki.net/PNG
- http://packages.debian.org/unstable/devel/cl-png.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-png/cl-png_${PV}.orig.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=png
-
-src_install() {
- common-lisp-install *.cl *.asd
- common-lisp-system-symlink
- dodoc COPYING README
-}
diff --git a/dev-lisp/cl-png/cl-png-0.2.1.ebuild b/dev-lisp/cl-png/cl-png-0.2.1.ebuild
deleted file mode 100644
index b2cde550ff83..000000000000
--- a/dev-lisp/cl-png/cl-png-0.2.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.2.1.ebuild,v 1.4 2004/07/14 15:59:17 agriffis Exp $
-
-inherit common-lisp
-
-DESCRIPTION="Common Lisp package to read and write PNG image files"
-HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
- http://www.cliki.net/PNG
- http://packages.debian.org/unstable/devel/cl-png.html"
-SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-png/cl-png_${PV}.orig.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=png
-
-src_install() {
- common-lisp-install *.cl *.asd
- common-lisp-system-symlink
- dodoc COPYING README
-}
-
-pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
-
-pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
-}
diff --git a/dev-lisp/cl-png/cl-png-0.2.ebuild b/dev-lisp/cl-png/cl-png-0.2.ebuild
deleted file mode 100644
index f5278c426983..000000000000
--- a/dev-lisp/cl-png/cl-png-0.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.2.ebuild,v 1.4 2004/06/24 23:49:39 agriffis Exp $
-
-inherit common-lisp
-
-DESCRIPTION="Common Lisp package to read and write PNG image files"
-HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
- http://www.cliki.net/PNG
- http://packages.debian.org/unstable/devel/cl-png.html"
-SRC_URI="http://www.pvv.ntnu.no/~musum/lisp/code/png-${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND="dev-lisp/common-lisp-controller
- virtual/commonlisp"
-
-CLPACKAGE=png
-
-S=${WORKDIR}/png-${PV}
-
-src_install() {
- common-lisp-install *.cl ${FILESDIR}/png.asd
- common-lisp-system-symlink
- dodoc COPYING README
-}
diff --git a/dev-lisp/cl-png/cl-png-0.4.ebuild b/dev-lisp/cl-png/cl-png-0.4.ebuild
index 70c5b4f60466..fc02bd60a565 100644
--- a/dev-lisp/cl-png/cl-png-0.4.ebuild
+++ b/dev-lisp/cl-png/cl-png-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.4.ebuild,v 1.5 2005/04/11 07:59:41 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.4.ebuild,v 1.6 2005/04/16 23:18:00 mkennedy Exp $
inherit common-lisp
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-png/cl-png_${PV}.orig.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="x86 ~ppc ~amd64"
IUSE=""
DEPEND="dev-lisp/common-lisp-controller
virtual/commonlisp"
diff --git a/dev-lisp/cl-png/files/digest-cl-png-0.2 b/dev-lisp/cl-png/files/digest-cl-png-0.2
deleted file mode 100644
index 01b73c3e0eec..000000000000
--- a/dev-lisp/cl-png/files/digest-cl-png-0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 63130e77c737fc821d38b2beba3787b2 png-0.2.tar.gz 29424
diff --git a/dev-lisp/cl-png/files/digest-cl-png-0.2.1 b/dev-lisp/cl-png/files/digest-cl-png-0.2.1
deleted file mode 100644
index 267ee9d6d57c..000000000000
--- a/dev-lisp/cl-png/files/digest-cl-png-0.2.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c8c940d4010598d7896429d8bb6ad86c cl-png_0.2.1.orig.tar.gz 29516
diff --git a/dev-lisp/cl-png/files/digest-cl-png-0.2.1-r1 b/dev-lisp/cl-png/files/digest-cl-png-0.2.1-r1
deleted file mode 100644
index 267ee9d6d57c..000000000000
--- a/dev-lisp/cl-png/files/digest-cl-png-0.2.1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c8c940d4010598d7896429d8bb6ad86c cl-png_0.2.1.orig.tar.gz 29516