summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gnupg/ChangeLog10
-rw-r--r--app-vim/gnupg/gnupg-2.1.ebuild37
-rw-r--r--app-vim/gnupg/metadata.xml5
3 files changed, 52 insertions, 0 deletions
diff --git a/app-vim/gnupg/ChangeLog b/app-vim/gnupg/ChangeLog
new file mode 100644
index 000000000000..d44b5d2709c1
--- /dev/null
+++ b/app-vim/gnupg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/gnupg
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gnupg/ChangeLog,v 1.1 2011/08/11 07:25:35 radhermit Exp $
+
+*gnupg-2.1 (11 Aug 2011)
+
+ 11 Aug 2011; Tim Harder <radhermit@gentoo.org> +gnupg-2.1.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/gnupg/gnupg-2.1.ebuild b/app-vim/gnupg/gnupg-2.1.ebuild
new file mode 100644
index 000000000000..3844c40713c0
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gnupg/gnupg-2.1.ebuild,v 1.1 2011/08/11 07:25:35 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: transparent editing of gpg encrypted files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3645"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt
+
+ rm -f README
+}
diff --git a/app-vim/gnupg/metadata.xml b/app-vim/gnupg/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/gnupg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>