summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/galeon/ChangeLog8
-rw-r--r--net-www/galeon/Manifest5
-rw-r--r--net-www/galeon/files/digest-galeon-1.2.121
-rw-r--r--net-www/galeon/galeon-1.2.12.ebuild132
4 files changed, 142 insertions, 4 deletions
diff --git a/net-www/galeon/ChangeLog b/net-www/galeon/ChangeLog
index abab5064f081..57b6ec1f0eed 100644
--- a/net-www/galeon/ChangeLog
+++ b/net-www/galeon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/galeon
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.68 2003/11/13 03:47:55 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.69 2003/11/23 12:25:27 obz Exp $
+
+*galeon-1.2.12 (23 Nov 2003)
+
+ 23 Nov 2003; Mike Gardiner <obz@gentoo.org> galeon-1.2.12.ebuild:
+ New version. Requires the mozilla 1.5->1.5b hack, or else it won't detect 1.5
+ correctly, nor build
12 Nov 2003; Sven Blumenstein <bazik@gentoo.org> galeon-1.3.10.ebuild:
Added ~sparc keyword.
diff --git a/net-www/galeon/Manifest b/net-www/galeon/Manifest
index 32893b655797..0261ad63a8fd 100644
--- a/net-www/galeon/Manifest
+++ b/net-www/galeon/Manifest
@@ -3,12 +3,11 @@ MD5 efc7f93d6d434b63396a368e1f663a95 galeon-1.2.10a.ebuild 3296
MD5 f51d76877c4c755010a203c6d2426ba5 galeon-1.3.8.ebuild 1578
MD5 6debf9a1120d61f5daac3d2078009116 galeon-1.2.11.ebuild 3403
MD5 113865fb372255f4cb65dcfb7c93023d galeon-1.3.10.ebuild 1674
-MD5 dcc714813f5e98f92a2fc51b13e06290 .ChangeLog.swp 16384
MD5 5f03f6469c31e45d5b0b4c3eee6b13d0 galeon-1.3.7.ebuild 1571
-MD5 8cf7caa380a1e7bfc90d28b5ba592e0b ChangeLog 10364
+MD5 705499f0a5af3d2b115b23b70ec751f6 ChangeLog 10560
MD5 c374d7a4340230a98c1ef9517b517675 galeon-1.3.9.ebuild 1585
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
-MD5 d09137cf898d689ba02c4607ce0e1c61 galeon-1.2.12.ebuild 3475
+MD5 1f72d39b7710cb23ea3f28345061c789 galeon-1.2.12.ebuild 3570
MD5 d7f05d8c910cd3bc11b799ef300ae13f files/galeon-1.2.6-to-printpreview.patch 448
MD5 ac03f7ff1c8c933092c3ff11d59e998c files/digest-galeon-1.2.11 66
MD5 436b77780200d51a954cfa3fc77e9e2d files/digest-galeon-1.2.12 66
diff --git a/net-www/galeon/files/digest-galeon-1.2.12 b/net-www/galeon/files/digest-galeon-1.2.12
new file mode 100644
index 000000000000..f285a6a33bfa
--- /dev/null
+++ b/net-www/galeon/files/digest-galeon-1.2.12
@@ -0,0 +1 @@
+MD5 301cc69894a4bb8ba7e9330acd6ebc66 galeon-1.2.12.tar.gz 4220707
diff --git a/net-www/galeon/galeon-1.2.12.ebuild b/net-www/galeon/galeon-1.2.12.ebuild
new file mode 100644
index 000000000000..aec19bc31a1c
--- /dev/null
+++ b/net-www/galeon/galeon-1.2.12.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.12.ebuild,v 1.1 2003/11/23 12:25:27 obz Exp $
+
+IUSE="nls"
+
+inherit eutils libtool gnome.org
+
+DESCRIPTION="A GNOME Web browser based on gecko (mozilla's rendering engine)"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://galeon.sourceforge.net"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+SLOT="0"
+
+RDEPEND=">=net-www/mozilla-1.3
+ >=gnome-base/gnome-libs-1.4.1.4
+ <=gnome-base/libglade-0.99.0
+ =gnome-base/gnome-vfs-1.0*
+ =gnome-base/gconf-1.0*
+ >=gnome-base/oaf-0.6.10
+ >=dev-libs/libxml-1.8.17
+ >=media-libs/gdk-pixbuf-0.18.0
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.17 )"
+ # bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/pkgconfig"
+
+pkg_setup() {
+
+ if [ ! -f ${ROOT}/usr/lib/mozilla/components/libwidget_gtk.so ]
+ then
+ eerror
+ eerror "It seems that your Mozilla was not compiled against gtk+-1.2,"
+ eerror "but rather gtk+-2.0. As Galeon does not support this setup yet,"
+ eerror "you will have to remerge Mozilla with gtk+-1.2 support. This"
+ eerror "can be done by taking \"gtk2\" out of your USE flags:"
+ eerror
+ eerror " # USE="-gtk2" emerge mozilla "
+ eerror
+ die "Need Mozilla compiled with gtk+-1.2!!"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Add UTF8 support to the google smart bookmarks. Note that
+ # it will probibly only work for a newly created bookmark ...
+ # <azarah@gentoo.org> (26 Dec 2002)
+ cd ${S}; epatch ${FILESDIR}/${PN}-1.2.7-google-UTF8.patch
+
+}
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=
+ local moz_ver="`pkg-config --modversion mozilla-xpcom | cut -d. -f1,2 2>/dev/null`"
+
+ # This galeon version doesnt actually support mozilla as version 1.5,
+ # however it does support 1.5b <obz@gentoo.org>
+ [ $moz_ver == "1.5" ] && moz_ver="1.5b"
+
+ use nls || myconf="${myconf} --disable-nls"
+ # use bonobo && myconf="${myconf} --enable-gnome-file-selector"
+
+ # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
+ # or #gentoo-hardened/irc.freenode
+ has_version "sys-devel/hardened-gcc" && append-flags "-yet_exec"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-mozilla-libs=${MOZILLA_FIVE_HOME} \
+ --with-mozilla-includes=${MOZILLA_FIVE_HOME}/include \
+ --without-debug --disable-werror \
+ --disable-applet \
+ --disable-werror \
+ --disable-install-schemas \
+ --enable-nautilus-view=no \
+ --with-mozilla-snapshot=${moz_ver} \
+ ${myconf} || die
+
+ emake || make || die
+}
+
+src_install() {
+
+ # galeon-config-tool was rewritten for 1.2.0 and causes sandbox
+ # violations if gconfd is shut down... The schemas seem to install
+ # fine without it (at least it seems like it... *sigh*)
+ #gconftool --shutdown
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+ rm -rf ${D}/var/lib/scrollkeeper
+
+}
+
+pkg_postinst() {
+
+ galeon-config-tool --fix-gconf-permissions
+ galeon-config-tool --pkg-install-schemas
+ scrollkeeper-update
+
+ if [ -z "`use gnome`" ]
+ then
+ einfo "Please make sure libglade was built with gnome support, or"
+ einfo "else galeon will not be able to start up."
+ einfo
+ einfo 'To do this, type: '
+ einfo 'USE="gnome" emerge libglade'
+ fi
+
+}
+