summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/bitcoind/ChangeLog10
-rw-r--r--net-p2p/bitcoind/bitcoind-0.4.4.ebuild91
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild98
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.3.ebuild98
-rw-r--r--net-p2p/bitcoind/metadata.xml1
5 files changed, 296 insertions, 2 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 8b259cdf2483..bf2748922a0c 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.11 2012/03/15 16:37:13 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.12 2012/03/15 16:46:25 blueness Exp $
+
+*bitcoind-0.5.3 (15 Mar 2012)
+*bitcoind-0.5.0.4 (15 Mar 2012)
+*bitcoind-0.4.4 (15 Mar 2012)
+
+ 15 Mar 2012; Anthony G. Basile <blueness@gentoo.org> +bitcoind-0.4.4.ebuild,
+ +bitcoind-0.5.0.4.ebuild, +bitcoind-0.5.3.ebuild:
+ Version bumps which address bug #407793
15 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
-bitcoind-0.4.3-r2.ebuild, -bitcoind-0.5.0.3-r2.ebuild,
diff --git a/net-p2p/bitcoind/bitcoind-0.4.4.ebuild b/net-p2p/bitcoind/bitcoind-0.4.4.ebuild
new file mode 100644
index 000000000000..eb7c1a6b4c79
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.4.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.4.4.ebuild,v 1.1 2012/03/15 16:46:25 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+eligius ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/crypto++
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-${PN}-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ cp "${FILESDIR}/0.4.2-Makefile.gentoo" "Makefile" || die
+ use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
+}
+
+src_compile() {
+ local OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=( "LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("DB_CXXFLAGS=-I$(db_includedir "${DB_VER}")")
+ OPTS+=("DB_LDFLAGS=-ldb_cxx-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_CXXFLAGS=-I${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ use upnp && OPTS+=(USE_UPNP=1)
+
+ cd src || die
+ emake "${OPTS[@]}" ${PN}
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild b/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild
new file mode 100644
index 000000000000..20ee8ef896a6
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild,v 1.1 2012/03/15 16:46:25 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/${PN}-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-${PN}-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
+}
+
+src_compile() {
+ local OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+}
diff --git a/net-p2p/bitcoind/bitcoind-0.5.3.ebuild b/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
new file mode 100644
index 000000000000..d51924be6965
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.5.3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.3.ebuild,v 1.1 2012/03/15 16:46:25 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ eligius? ( http://luke.dashjr.org/programs/bitcoin/files/0.5.2-eligius_sendfee.patch.xz )
+"
+
+LICENSE="MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples ssl upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ cd src || die
+ use eligius && epatch "${WORKDIR}/0.5.2-eligius_sendfee.patch"
+}
+
+src_compile() {
+ local OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ use ssl && OPTS+=(USE_SSL=1)
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+}
diff --git a/net-p2p/bitcoind/metadata.xml b/net-p2p/bitcoind/metadata.xml
index 45871a7c2afa..e5803dcd78bf 100644
--- a/net-p2p/bitcoind/metadata.xml
+++ b/net-p2p/bitcoind/metadata.xml
@@ -10,7 +10,6 @@
<name>Luke Dashjr</name>
</maintainer>
<use>
- <flag name='bip17'>Enable validation of new P2SH transactions</flag>
<flag name='eligius'>Enable using lower fees accepted by Eligius</flag>
<flag name='upnp'>Enable Universal Plug and Play</flag>
</use>