summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/jdk/jdk-1.2.2_rc4-r1.ebuild35
-rw-r--r--media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild (renamed from media-libs/libungif/libungif-4.1.0b1-r1.ebuild)2
-rw-r--r--media-libs/tiff/tiff-v3.5.5-r1.ebuild52
-rw-r--r--net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild34
-rw-r--r--net-fs/netatalk/netatalk-1.4_beta2-r1.ebuild (renamed from net-fs/netatalk/netatalk-1.4b2-r1.ebuild)2
-rw-r--r--net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild (renamed from net-ftp/proftpd/proftpd-1.2.0rc2-r1.ebuild)2
6 files changed, 38 insertions, 89 deletions
diff --git a/dev-lang/jdk/jdk-1.2.2_rc4-r1.ebuild b/dev-lang/jdk/jdk-1.2.2_rc4-r1.ebuild
new file mode 100644
index 000000000000..843bbff483f1
--- /dev/null
+++ b/dev-lang/jdk/jdk-1.2.2_rc4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jdk/jdk-1.2.2_rc4-r1.ebuild,v 1.1 2000/08/16 16:45:45 achim Exp $
+
+P=jdk-1.2.2
+A=jdk-1.2.2-RC4-linux-i386-glibc-2.1.2.tar.bz2
+S=${WORKDIR}/jdk1.2.2
+DESCRIPTION="Blackdown JDK 1.2.2"
+SRC_URI="ftp://gd.tuwien.ac.at/opsys/linux/java/JDK-1.2.2/i386/rc4/jdk-1.2.2-RC4-linux-i386-glibc-2.1.2.tar.bz2"
+HOMEPAGE="http://www.blackdown.org/java-linux.html"
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ dodir /opt/jdk-1.2.2
+ cp -a ${S}/bin ${D}/opt/jdk-1.2.2
+ cp -a ${S}/demo ${D}/opt/jdk-1.2.2
+ cp -a ${S}/include ${D}/opt/jdk-1.2.2
+ cp -a ${S}/lib ${D}/opt/jdk-1.2.2
+ cp -a ${S}/jre ${D}/opt/jdk-1.2.2
+ cp ${S}/src.jar ${D}/opt/jdk-1.2.2
+ into /usr
+ dodoc COPYRIGHT LICENSE README README.PRE-RELEASE README.linux
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst () {
+ ln -s ${ROOT}/opt/jdk-1.2.2 ${ROOT}/opt/java
+}
+
+
diff --git a/media-libs/libungif/libungif-4.1.0b1-r1.ebuild b/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild
index dec1bc343a45..90dcefa37431 100644
--- a/media-libs/libungif/libungif-4.1.0b1-r1.ebuild
+++ b/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libungif/libungif-4.1.0b1-r1.ebuild,v 1.2 2000/08/16 04:38:08 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild,v 1.1 2000/08/16 16:45:45 achim Exp $
P=libungif-4.1.0b1
A=${P}.tar.gz
diff --git a/media-libs/tiff/tiff-v3.5.5-r1.ebuild b/media-libs/tiff/tiff-v3.5.5-r1.ebuild
deleted file mode 100644
index fbe99c044751..000000000000
--- a/media-libs/tiff/tiff-v3.5.5-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tiff/tiff-v3.5.5-r1.ebuild,v 1.2 2000/08/16 04:38:09 drobbins Exp $
-
-P=tiff-v3.5.5
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="libtiff"
-SRC_URI="http://www.libtiff.org/"${A}
-HOMEPAGE="http://www.libtiff.org/"
-
-src_compile() {
- cd ${S}
- ./configure --noninteractive
- cd libtiff
- cp Makefile Makefile.orig
- sed -e "s/-O/${CFLAGS}/" Makefile.orig > Makefile
- cd ../tools
- cp Makefile Makefile.orig
- sed -e "s/-O/${CFLAGS}/" Makefile.orig > Makefile
- cd ..
- make
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp ${O}/files/config.site .
- echo "DIR_HTML=\"${D}/usr/doc/${P}/html\"" >> config.site
- cp configure configure.orig
- sed -e "s:if \[ -r /lib/libc.*:if \[ -r /lib/libc\.so\.6 \]\; then:" \
- configure.orig > configure
-}
-
-src_install() {
- cd ${S}
- into /usr
- dodir /usr/bin
- dodir /usr/lib
- dodir /usr/man
- dodir /usr/doc
- dodoc COPYRIGHT README TODO VERSION
- dodir /usr/doc/${P}/html
- make install
- prepman
- gzip ${D}/usr/doc/${P}/html/*.html
- gzip ${D}/usr/doc/${P}/html/images/*
- rm ${D}/usr/lib/libtiff.so.3
- mv ${D}/usr/lib/libtiff.so.3.5. ${D}/usr/lib/libtiff.so.3.5.5
- rm -r /tiff.sw.tools
-}
diff --git a/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild b/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild
deleted file mode 100644
index b334f28a00f3..000000000000
--- a/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/isdn4k-utils/isdn4k-utils.v3.1p1-r1.ebuild,v 1.2 2000/08/16 04:38:13 drobbins Exp $
-
-P=isdn4k-utils.v3.1p1
-A=isdn4k-utils.v3.1pre1.tar.gz
-S=${WORKDIR}/isdn4k-utils
-DESCRIPTION="ISDN-4-Linux Utils"
-SRC_URI="ftp://ftp.isdn4linux.de/pub/isdn4linux/utils/"${A}
-HOMEPAGE="http://www.isdn4linux.de/"
-
-src_compile() {
- cd ${S}
- sed -e "s:CONFIG_KERNELDIR=.*:CONFIG_KERNELDIR='${WORKDIR}/../../../sys-kernel/linux-UP-2\.2\.17p13/work/linux':" ${O}/files/${P}.config > .config
- make subconfig
- make
-}
-
-src_install() {
- cd ${S}
- dodir /dev
- dodir /usr/sbin
- dodir /usr/bin
- make install DESTDIR=${D}
- dodir /usr/doc/${P}
- mv ${D}/usr/doc/vbox ${D}/usr/doc/${P}
- dodoc COPYING NEWS README Mini-FAQ/isdn-faq.txt
-
-}
-
-
-
-
diff --git a/net-fs/netatalk/netatalk-1.4b2-r1.ebuild b/net-fs/netatalk/netatalk-1.4_beta2-r1.ebuild
index 73104b260c42..a10375393578 100644
--- a/net-fs/netatalk/netatalk-1.4b2-r1.ebuild
+++ b/net-fs/netatalk/netatalk-1.4_beta2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.4b2-r1.ebuild,v 1.2 2000/08/16 04:38:13 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/netatalk/netatalk-1.4_beta2-r1.ebuild,v 1.1 2000/08/16 16:45:45 achim Exp $
P=netatalk-1.4b2
A=${P}.tar.gz
diff --git a/net-ftp/proftpd/proftpd-1.2.0rc2-r1.ebuild b/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild
index 44166d40c11a..4f1a435ca0b1 100644
--- a/net-ftp/proftpd/proftpd-1.2.0rc2-r1.ebuild
+++ b/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.0rc2-r1.ebuild,v 1.2 2000/08/16 04:38:15 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.0_rc2-r1.ebuild,v 1.1 2000/08/16 16:45:45 achim Exp $
P=proftpd-1.2.0rc2
A="${P}.tar.gz"