summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/gkrellm-hddtemp/ChangeLog8
-rw-r--r--x11-plugins/gkrellm-hddtemp/Manifest4
-rw-r--r--x11-plugins/gkrellm-hddtemp/files/digest-gkrellm-hddtemp-0.2_beta1
-rw-r--r--x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta.ebuild58
4 files changed, 68 insertions, 3 deletions
diff --git a/x11-plugins/gkrellm-hddtemp/ChangeLog b/x11-plugins/gkrellm-hddtemp/ChangeLog
index 6a4e5a6ae943..4f2538dae4fd 100644
--- a/x11-plugins/gkrellm-hddtemp/ChangeLog
+++ b/x11-plugins/gkrellm-hddtemp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gkrellm-hddtemp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/ChangeLog,v 1.4 2003/02/12 15:56:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/ChangeLog,v 1.5 2003/05/17 11:53:29 mholzer Exp $
+
+*gkrellm-hddtemp-0.2_beta (17 May 2003)
+
+ 17 May 2003; Martin Holzer <mholzer@gentoo.org>
+ gkrellm-hddtemp-0.2_beta.ebuild:
+ Version bumped. Ebuild submitted by moonlite@linux.nu in #20370.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/x11-plugins/gkrellm-hddtemp/Manifest b/x11-plugins/gkrellm-hddtemp/Manifest
index 6d1117f68ff0..05dae45259d4 100644
--- a/x11-plugins/gkrellm-hddtemp/Manifest
+++ b/x11-plugins/gkrellm-hddtemp/Manifest
@@ -1,5 +1,5 @@
-MD5 407d1e951da09acb12c39f743e1a63a4 ChangeLog 898
+MD5 33a57443b2a2cb97c337097f8b47d341 ChangeLog 1093
MD5 a79bfb86ef8d116b5174046ae790e429 gkrellm-hddtemp-0.1.ebuild 1061
-MD5 4c1155f45a64fff06a8f026e8dcd3720 gkrellm-hddtemp-0.2_beta.ebuild 1105
+MD5 03ed789ed7220b74605841ee9d194bca gkrellm-hddtemp-0.2_beta.ebuild 1517
MD5 a9f57bac01537cef132c947c68eb3977 files/digest-gkrellm-hddtemp-0.1 69
MD5 d3cc852ee5cbc0155681cecb5e3afa65 files/digest-gkrellm-hddtemp-0.2_beta 75
diff --git a/x11-plugins/gkrellm-hddtemp/files/digest-gkrellm-hddtemp-0.2_beta b/x11-plugins/gkrellm-hddtemp/files/digest-gkrellm-hddtemp-0.2_beta
new file mode 100644
index 000000000000..a829f6d9e28e
--- /dev/null
+++ b/x11-plugins/gkrellm-hddtemp/files/digest-gkrellm-hddtemp-0.2_beta
@@ -0,0 +1 @@
+MD5 b4f3b90692acbce1f74cac05ce2264fa gkrellm-hddtemp-0.2-beta.tar.gz 10923
diff --git a/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta.ebuild b/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta.ebuild
new file mode 100644
index 000000000000..19573367a993
--- /dev/null
+++ b/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta.ebuild,v 1.1 2003/05/17 11:53:29 mholzer Exp $
+
+MY_P=${P/_beta/-beta}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="a GKrellM2 plugin for hddtemp (which reads the temperature of SMART IDE hard drives)"
+SRC_URI="http://coredump.free.fr/linux/${MY_P}.tar.gz"
+HOMEPAGE="http://coredump.free.fr/linux/harddrive.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="=app-admin/gkrellm-2*"
+RDEPEND=">=app-admin/hddtemp-0.3_beta6"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # patch Makefile
+ sed -i "s:^CFLAGS.*:CFLAGS=${CFLAGS} -fPIC:" Makefile
+}
+
+src_compile() {
+ GKRELLM1=0
+ GKRELLM2=0
+ if [ -f /usr/bin/gkrellm2 ]; then
+ GKRELLM2=1
+ einfo "Building plugin for gkrellm-2.*"
+ make gkrellm2 || die
+ fi
+ if [ -f /usr/bin/gkrellm ]; then
+ GKRELLM1=1
+ einfo "Building plugin for gkrellm-1.*"
+ make gkrellm1 || die
+ fi
+}
+
+src_install() {
+ dodoc README COPYING
+ if [ $GKRELLM1 = 1 ]; then
+ einfo "Installing plugin for gkrellm-1.*"
+ insinto /usr/lib/gkrellm/plugins
+ doins gkrellm-hddtemp.so
+ fi
+ if [ $GKRELLM2 = 1 ]; then
+ einfo "Installing plugin for gkrellm-2.*"
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrellm-hddtemp.so
+ fi
+}
+
+pkg_postinst() {
+ einfo "hddtemp has to be suid root to allow regular users to run this plugin."
+ einfo "To make it suid root, run"
+ einfo ""
+ einfo "\tchmod u+s /usr/bin/hddtemp"
+}