summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/p7zip/ChangeLog6
-rw-r--r--app-arch/p7zip/files/7z5
-rw-r--r--app-arch/p7zip/files/7za5
-rw-r--r--app-arch/p7zip/files/digest-p7zip-0.911
-rw-r--r--app-arch/p7zip/p7zip-0.91.ebuild33
-rw-r--r--app-arch/p7zip/p7zip-4.27.ebuild12
6 files changed, 18 insertions, 44 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index f39706a9e379..1bc3b441f9b3 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.27 2005/09/24 15:00:59 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.28 2005/09/25 09:29:39 radek Exp $
+
+ 25 Sep 2005; Radoslaw Stachowiak <radek@gentoo.org> files/7z, +files/7za,
+ -p7zip-0.91.ebuild, p7zip-4.27.ebuild:
+ fixed bug #107107 with wrong wrapper/symlink usage. removed old version.
24 Sep 2005; Radoslaw Stachowiak <radek@gentoo.org> p7zip-4.27.ebuild:
Removed ppc-macos keyword due to compilation bug
diff --git a/app-arch/p7zip/files/7z b/app-arch/p7zip/files/7z
index bc1796544a00..ae6974cfcd78 100644
--- a/app-arch/p7zip/files/7z
+++ b/app-arch/p7zip/files/7z
@@ -1,4 +1,5 @@
#!/bin/sh
-# 7z wrapper
+# 7z wrapper, p7zip, should be called with full path
+# so symlink and copy should not be used instead.
-/usr/lib/7z/7z $@
+exec /usr/lib/p7zip/7z $@
diff --git a/app-arch/p7zip/files/7za b/app-arch/p7zip/files/7za
new file mode 100644
index 000000000000..824a92c9be64
--- /dev/null
+++ b/app-arch/p7zip/files/7za
@@ -0,0 +1,5 @@
+#!/bin/sh
+# 7za wrapper, p7zip, should be called with full path
+# so symlink and copy should not be used instead.
+
+exec /usr/lib/p7zip/7za $@
diff --git a/app-arch/p7zip/files/digest-p7zip-0.91 b/app-arch/p7zip/files/digest-p7zip-0.91
deleted file mode 100644
index f8324cf8b172..000000000000
--- a/app-arch/p7zip/files/digest-p7zip-0.91
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8c6a7b49f360917cbdd8391f3a926a19 p7zip_0.91.tar.bz2 448147
diff --git a/app-arch/p7zip/p7zip-0.91.ebuild b/app-arch/p7zip/p7zip-0.91.ebuild
deleted file mode 100644
index d5814089671a..000000000000
--- a/app-arch/p7zip/p7zip-0.91.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-0.91.ebuild,v 1.2 2005/01/01 11:50:22 eradicator Exp $
-
-DESCRIPTION="Port of 7-Zip archiver for Unix."
-HOMEPAGE="http://p7zip.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.bz2"
-
-SLOT="0"
-IUSE="doc"
-LICENSE="LGPL-2.1"
-KEYWORDS="~x86"
-
-S=${WORKDIR}/${PN}_${PV}
-
-src_compile ()
-{
- make || die "compilation error"
-}
-
-src_install ()
-{
- dodir /usr/lib/7z
- cp -R bin/Codecs bin/Formats ${D}/usr/lib/7z
- cp bin/7z ${D}/usr/lib/7z
-
- dobin ${FILESDIR}/7z
- dobin bin/7za
-
- dodoc ChangeLog README TODO
-
- use doc && dohtml -r html/* ${D}/usr/share/doc/${P}
-}
diff --git a/app-arch/p7zip/p7zip-4.27.ebuild b/app-arch/p7zip/p7zip-4.27.ebuild
index aef53fa97864..2070b8d2e47e 100644
--- a/app-arch/p7zip/p7zip-4.27.ebuild
+++ b/app-arch/p7zip/p7zip-4.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.27.ebuild,v 1.2 2005/09/24 15:00:59 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.27.ebuild,v 1.3 2005/09/25 09:29:39 radek Exp $
inherit eutils toolchain-funcs
@@ -31,15 +31,13 @@ src_compile() {
}
src_install() {
- dobin bin/7za || die "dobin 7za"
-
- # currently (4.27) not needed, due to separate 7z
- #dosym 7za /usr/bin/7z
- dobin bin/7z || die "dobin 7z"
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ dobin ${FILESDIR}/7za || die "dobin 7za"
+ dobin ${FILESDIR}/7z || die "dobin 7z"
dodir /usr/lib/${PN}
exeinto /usr/lib/${PN}
- doexe bin/7z bin/7za
+ doexe bin/7z bin/7za bin/7zCon.sfx
dodir /usr/lib/${PN}/Codecs
exeinto /usr/lib/${PN}/Codecs
doexe bin/Codecs/*