summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-www/lynx/ChangeLog9
-rw-r--r--net-www/lynx/files/digest-lynx-2.8.4.1c4
-rw-r--r--net-www/lynx/files/lynx-2.8.4.1c-gentoo.patch8
-rw-r--r--net-www/lynx/lynx-2.8.4.1c.ebuild70
4 files changed, 90 insertions, 1 deletions
diff --git a/net-www/lynx/ChangeLog b/net-www/lynx/ChangeLog
index af35a9607088..33f365f779bb 100644
--- a/net-www/lynx/ChangeLog
+++ b/net-www/lynx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/lynx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.6 2002/07/14 20:25:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.7 2002/08/26 08:48:57 aliz Exp $
+
+*lynx-2.8.4.1c (26 Aug 2002)
+
+ 26 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> lynx-2.8.4.1c.ebuild :
+ Updated to latest patchlevel to fix CRLF injection. More info availabe
+ at http://online.securityfocus.com/archive/1/288054/2002-08-16/2002-08-22/0
+ and http://online.securityfocus.com/archive/1/288620/2002-08-16/2002-08-22/0
*lynx-2.8.4a-r4 (2 June 2002)
diff --git a/net-www/lynx/files/digest-lynx-2.8.4.1c b/net-www/lynx/files/digest-lynx-2.8.4.1c
new file mode 100644
index 000000000000..23f1e5954362
--- /dev/null
+++ b/net-www/lynx/files/digest-lynx-2.8.4.1c
@@ -0,0 +1,4 @@
+MD5 6916c0127839f1e454052b683e4691c4 lynx2.8.4rel.1.tar.bz2 1940531
+MD5 d209e52d8182c7c12d784e90c0890ee4 lynx2.8.4rel.1a.patch 7530
+MD5 a687a3d2465d5fd42ce686485dbf71eb lynx2.8.4rel.1b.patch 8939
+MD5 728c8dfde1484b68940673ccf060707e lynx2.8.4rel.1c.patch 9270
diff --git a/net-www/lynx/files/lynx-2.8.4.1c-gentoo.patch b/net-www/lynx/files/lynx-2.8.4.1c-gentoo.patch
new file mode 100644
index 000000000000..0d28397d1b0c
--- /dev/null
+++ b/net-www/lynx/files/lynx-2.8.4.1c-gentoo.patch
@@ -0,0 +1,8 @@
+--- src/LYStrings.c Wed May 29 14:41:43 2002
++++ src/LYStrings.c~ Wed May 29 14:41:21 2002
+@@ -1,3 +1,4 @@
++#include <term.h>
+ #include <HTUtils.h>
+ #include <HTCJK.h>
+ #include <UCAux.h>
+
diff --git a/net-www/lynx/lynx-2.8.4.1c.ebuild b/net-www/lynx/lynx-2.8.4.1c.ebuild
new file mode 100644
index 000000000000..f45b832a6a51
--- /dev/null
+++ b/net-www/lynx/lynx-2.8.4.1c.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4.1c.ebuild,v 1.1 2002/08/26 08:48:57 aliz Exp $
+
+MY_PV=${PV/.1c/rel.1}
+S=${WORKDIR}/${PN}2-8-4
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/${PN}/${PN}2.8.4/${PN}${MY_PV}.tar.bz2
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}a.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}b.patch
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/${PN}${MY_PV}c.patch"
+KEYWORDS="x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+ unpack ${PN}${MY_PV}.tar.bz2
+ cd ${S}
+
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}a.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}b.patch || die
+ patch -p1 < ${DISTDIR}/${PN}${MY_PV}c.patch || die
+
+ # GCC3.1 support -- check if it's really needed in
+ # future. Some users report complete success with -r3 --
+ # credit to lostlogix and carpaski. Resolves #3172
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=yes"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ CFLAGS="${CFLAGS} -DANSI_VARARGS"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
+ --libdir=/etc/lynx --enable-cgi-links --enable-prettysrc \
+ --enable-nsl-fork --enable-file-upload --enable-read-eta \
+ --enable-libjs --enable-color-style --enable-scrollbar \
+ --enable-included-msgs --with-zlib --host=${CHOST} ${myconf}
+ assert
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm ${D}/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}